maroseyka
?>

На Python Треугольник Паскаля Даны два числа n и m. Создайте массив n×m и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j] = 1, A[i][0] = 1 Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. Входные данные Вводятся два натуральных числа n и m, не превышающих 100. Выходные данные Выведите данный массив на экран. Примеры Ввод Вывод 3 3 1 1 1 1 2 3 1 3 6

Информатика

Ответы

maximovpavel9114

n, m = map(int, input().split())

pascal = [[1] * n for i in range(m)]

for i in range(1, m):

   for j in range(1, n):

       pascal[i][j] = pascal[i-1][j] + pascal[i][j-1]

for i in range(len(pascal)):

   print(*pascal[i])

orantus3
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]
dashasnegirva
Class ArrayEven{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArrayCell:
  for(int cCell = 0; cCell<eArray.length-1; cCell++){
   if(eArray[cCell]%2==0)continue;
   else for(int eCell = cCell+1; eCell<eArray.length-1; eCell++)
   if(eArray[eCell]%2==0){
    eArray[eArray.length-1]=eArray[cCell];
    eArray[cCell]=eArray[eCell];
    eArray[eCell]=eArray[eArray.length-1];
    continue eArrayCell;
   }
   break;
  }
  for(int cCell = 0; cCell<eArray.length-1; cCell++)System.out.print(eArray[cCell]+" ");
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На Python Треугольник Паскаля Даны два числа n и m. Создайте массив n×m и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j] = 1, A[i][0] = 1 Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. Входные данные Вводятся два натуральных числа n и m, не превышающих 100. Выходные данные Выведите данный массив на экран. Примеры Ввод Вывод 3 3 1 1 1 1 2 3 1 3 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilonchick679
egornostaeva
nikolotovas
annaan-dr582
TSKaraulova
Galkin Vladimirovich729
ilyatamurov
sashakrotova943
sbalashov62
Шмидт Ирина
u-bhank
Anna_Kamil
Эдуардович873
Cannabikh
arevik2307
▲