Щербаков33
?>

Для Pascal Составить программу шифровки методом цифр, используя ключевое слово «РЕСПУБЛИКА». ​

Информатика

Ответы

Elen-Fler
Const
    handsfree = false;

var
    a: array[1..500] of integer;
    i, n, j: integer;
    temp: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(500) + 1
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100000);
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {сортировочка пузыречком по убыванию}
    for i := 1 to n - 1 do
        for j := i + 1 to n do
            if A[i] < A[j] then begin
                temp := A[i];
                A[i] := A[j];
                A[j] := temp;
            end;
    
    {вывод массива}
    writeln('Вывод массива:');
    for i := 1 to n do
        write(a[i], ' ');
    writeln();
    
    writeln('Наибольшая купюра = ', a[1], a[2]);
end.

Вывод (при handfree = true)
Данные массива:
14326 83146 41199 15524 45803 60252 17062 77469 66347 48671 98328 61915 65607 88427 62486 50724 86714 97620 39326 61552 6654 93608 22718 77352 63933 29408 99498 63255 23230 7413 67602 67278 76628 87483 71421 12343 30770
Вывод массива:
99498 98328 97620 93608 88427 87483 86714 83146 77469 77352 76628 71421 67602 67278 66347 65607 63933 63255 62486 61915 61552 60252 50724 48671 45803 41199 39326 30770 29408 23230 22718 17062 15524 14326 12343 7413 6654
Наибольшая купюра = 9949898328
notka19746
Задание №1.

k = int(input('Начало диапазона '))
n = int(input('Конец диапазона '))
a = [0] * n # создание массива с n количеством элементов
for i in range(n): # заполнение массива
   a[i] = i
a[1] = 0

m = 2 # замена на 0 начинается с 3-го элемента

while m < n: # перебор всех элементов до заданного числа
  if a[m] != 0:
     j = m * 2
    while j < n:
        a[j] = 0
        j = j + m
       m += 1

# вывод простых чисел на экран
b = []
for i in a:
      if a[i] != 0 and i >= k:
      b.append(a[i])

del a
print(b)

Задание №2

count = 0
for i in range(13):
    for j in range(11):
        for k in range(9):
            if 185 == i*15+j*17+k*21:
                count += 1
                print(i,j,k)
print('Всего

Задание №3

x = int(input())
print('\n'.join(
str(n) for n in range(x+1)
if all(x != 0 and n % x == 0 for x in map(int, str(n

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Для Pascal Составить программу шифровки методом цифр, используя ключевое слово «РЕСПУБЛИКА». ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksandrovich1669
masha812
Alesander-Isaev684
elena-ruzadom
igschuschkov6211
hristos1212
Роман1406
Orestov563
Gainalii1912
derkachn6429
ganul
sharaeva-is
Некрасов Валентина1097
Марина1101
Присакарь520