КузменковаЖигулин
?>

Используя цикл while, напишите программу, вычисляющую сумму всех чётных чисел от 1 до введённого целого числа m.

Информатика

Ответы

ribcage52
var i,m,sum: integer; beginread(m); while i<m dobegini:=i+1;if i mod 2 = 0 then sum:=sum+i; end;write(sum); end.

Пример работы:

2+4+6 = 12


Используя цикл while, напишите программу, вычисляющую сумму всех чётных чисел от 1 до введённого цел
katrin819

Программа:
С#:

using System;

class HelloWorld {

 static void Main() {

   Console.Write("x = ");

   double x = Convert.ToDouble(Console.ReadLine());

   

   Console.Write("y = ");

   double y = Convert.ToDouble(Console.ReadLine());

   

   double HalfCount = (x + y) / 2;

   double DoubleProduct = 2 * x * y;

   

   if (x < y) {

       x = HalfCount;

       y = DoubleProduct;

   } else {

       y = HalfCount;

       x = DoubleProduct;

   }

   

   Console.WriteLine($"x = {x}; y = {y}");

 }

}

В начале вводим значения переменных x, y (типа double (float), действительные числа). Отдельными переменными находим половину суммы и удвоенное произведение введённых чисел. Находим меньшее число и присваиваем значения согласно условию. В конце - выводим результат.


Нужна с написанием программы на C# Даны действительные числа x и y, не равные друг другу. Меньшее из
filial2450
пропуски в тексте: База данных - это

, предназначенный(-ая) для длительного хранения во внешней памяти компьютера и постоянного применения.
Система управления базами данных - это

, предназначенный(-ая) для работы с БД.
База данных, основанная на табличной форме организации данных называется

.
В такой базе данных столбец называется

, а строка -

.
Поле, позволяющее сделать каждую запись уникальной, называют

.

реляционная, организованная совокупность данных, иерархической, информационная система, произвольный набор информации, первым, программа, ключевым, полем, записью, ячейкой

Все ответы проверяются

30000
ДОБАВИТЬ ОТВЕТ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя цикл while, напишите программу, вычисляющую сумму всех чётных чисел от 1 до введённого целого числа m.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vasiliyglukhov
tanya14757702
X2755070
pokrov777krest
ilyatamurov
gen218
bikemaster
saryba
Палкина-Дроздова
Бернард pokerman
samofar
Shtorm-Shoe
zagadka27
Imarmy67
frsergeysavenok