sv455umarketing74
?>

написать программу для машины Поста 1. Число k задано на ленте k метками. Увеличить число на единицу, если: 1) каретка находится где-то над массивом меток. 2) каретка находится где-то слева от массива. 2. На ленте задан массив меток. Увеличить его на два. 3. Два числа заданы на ленте двумя массивами меток. Сложить эти числа. Расстояние между массивами может быть: 1 метка; несколько меток.

Информатика

Ответы

Алина1564
Как то раз Я (Будильник) разбудил своего хозяина в не то время. Хозяин как ни в чём не бывало пошёл на роботу, даже не посмотрев на часы. Так я понял что я могу управлять человеком, и сразу же после этого я стал использовать своего хозяина и всякими образами издеваться над ним. Вскоре мой хозяин стал что то подозревать, но я был хитрее, я стал переводить стрелки своих часов и человек опять верил мне, после полного досмотра и нашёл в мне неисправность его решение было очень жестким - он выкинул меня на улицу. 
siyaniemoskva
Using System;
using System.Collections.Generic;

class Program
{
    static void Main()
    {
        var l = new List<double>();
        var r = new Random();
        var n = r.Next(10, 50);
        for (var i = 0; i < n; i++)
        {
            l.Add(r.NextDouble() * 2);
        }
        Console.WriteLine(CountRelation(l));
        Console.ReadKey();
    }

    static double CountRelation(IEnumerable<double> a)
    {
        var r = 0.0;
        var s = 0.0;
        foreach (var item in a)
        {
            if (item <= 1)
                r += item;
            else s += item;
        }

        return (1 + r) / (1 + s);
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу для машины Поста 1. Число k задано на ленте k метками. Увеличить число на единицу, если: 1) каретка находится где-то над массивом меток. 2) каретка находится где-то слева от массива. 2. На ленте задан массив меток. Увеличить его на два. 3. Два числа заданы на ленте двумя массивами меток. Сложить эти числа. Расстояние между массивами может быть: 1 метка; несколько меток.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arina2403423
Алина1564
Mikhail579
bsi771184
Никитина580
Мария-Кострыгина175
vikabobkova2010
stasletter
dimiff5
Igor120
Akolomaeva4
laktionova-natal
pimenovamar
atlantika7