Verdievruslan
?>

На языке программирования С++ Яркости пикселей рисунка закодированы числами от 0 до 255 в виде матрицы. Преобразовать рисунок в черно-белый по следующему алгоритму: вычислить среднюю яркость пикселей по всему рисунку все пиксели, яркость которых меньше средней, сделать черными (записать код 0), а остальные -– белыми (код 255) Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел в диапазоне от 0 до 255, разделённых пробелами. Выходные данные Программа должна вывести в первой строчке среднее значение яркости для заданного рисунка с точностью 4 знака в дробной части. В следующих N строчках выводится построенная матрица, соответствующая чёрно-белому изображению. Примеры Входные данные 4 4 12 14 67 45 32 87 45 63 69 45 14 11 40 12 35 15 Выходные данные 37.8750 0 0 255 255 0 255 255 255 255 255 0 0 255 0 0 0

Информатика

Ответы

opel81
DATA 101,98,100,108,97,106,99,100,112,96,107,98
DIM a(1 TO 12) AS INTEGER
DIM b(1 TO 12) AS INTEGER, c(1 TO 12) AS INTEGER
DIM i AS INTEGER, ib AS INTEGER, ic AS INTEGER
CLS
ib = 0: ic = 0
FOR i = 1 TO 12
        READ a(i)
        SELECT CASE a(i)
        CASE 100
                ib = ib + 1
                b(ib) = i
        CASE IS > 100
                ic = ic + 1
                c(ic) = i
        END SELECT
NEXT i

PRINT "План (100%) в месяцах: ";
FOR i = 1 TO ib
        PRINT b(i);
NEXT i
PRINT
PRINT "перевыполнение плана в месяцах ";
FOR i = 1 TO ic
        PRINT c(i);
NEXT i
END

Результат выполнения программы:
План (100%) в месяцах:  3  8
перевыполнение плана в месяцах  1  4  6  9  11
Vyacheslavovna1108

var k1,k2,k3,k4,k:integer;

begin

writeln('Перед вами программа, которая умеет вычислять количество информации');

writeln('по выбранному наугад шарику из мешка.');

writeln('Введите число шаров белого цвета:');

readln(k1);

writeln('Введите число шаров чёрного цвета:');

readln(k2);

writeln('Введите число шаров синего цвета:');

readln(k3);

writeln('Введите число шаров красного цвета:');

readln(k4);

k:=k1+k2+k3+k4;

if k1<>0 then

writeln('Во фразе «Выпал белый шар» содержится ',log2(k/k1):4:1,' бит(а) информации');

if k2<>0 then

writeln('Во фразе «Выпал чёрный шар» содержится ',log2(k/k2):4:1,' бит(а) информации');

if k3<>0 then

writeln('Во фразе «Выпал синий шар» содержится ',log2(k/k3):4:1,' бит(а) информации');

if k4<>0 then

writeln('Во фразе «Выпал красный шар» содержится ',log2(k/k4):4:1,' бит(а) информации');

end.

Пример:

Перед вами программа, которая умеет вычислять количество информации

по выбранному наугад шарику из мешка.

Введите число шаров белого цвета:

100

Введите число шаров чёрного цвета:

0

Введите число шаров синего цвета:

200

Введите число шаров красного цвета:

100

Во фразе «Выпал белый шар» содержится  2.0 бит(а) информации

Во фразе «Выпал синий шар» содержится  1.0 бит(а) информации

Во фразе «Выпал красный шар» содержится  2.0 бит(а) информации

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке программирования С++ Яркости пикселей рисунка закодированы числами от 0 до 255 в виде матрицы. Преобразовать рисунок в черно-белый по следующему алгоритму: вычислить среднюю яркость пикселей по всему рисунку все пиксели, яркость которых меньше средней, сделать черными (записать код 0), а остальные -– белыми (код 255) Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел в диапазоне от 0 до 255, разделённых пробелами. Выходные данные Программа должна вывести в первой строчке среднее значение яркости для заданного рисунка с точностью 4 знака в дробной части. В следующих N строчках выводится построенная матрица, соответствующая чёрно-белому изображению. Примеры Входные данные 4 4 12 14 67 45 32 87 45 63 69 45 14 11 40 12 35 15 Выходные данные 37.8750 0 0 255 255 0 255 255 255 255 255 0 0 255 0 0 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tanyaandreeva728
argo951385
insan10
Deniskotvitsky6422
VladimirovnaKashintsev1151
magichands68
Volkovapavel
priexali
martinzdraste
Vello Olga
tochkamail7
D.Yu. Polina1703
fucingprinces30
shajmasha
dobrovolsky-tmz1