shilinmikhaillg
?>

надо написать программу на языке С Вычислите таблицу значений выражения (x3+1)/(x-3)+x. Начальное и конечное значение вводит пользователь. Предусмотрите проверку корректности (начало меньше конца

Информатика

Ответы

AOS2015

а можно во а как это?

lenapopovich556510

Короче. Вот код.

def matrix_gen(gen, n, m):    Matrix = [];    for i in range(n):        a = [];        for j  in range(m):            a.append(gen[j]);        Matrix.append(a);    return Matrix;

Объяснение

Сначало ты инициализируешь функицю с названием "matrix_gen", которая принимает 3 параметра, 'gen' -- это генератор которые ты будешь использовать. 'n' & 'm' это размер матрицы.

Второй строчкой ты инициалихируешь пустой массив, которые похже заполнишь. Третей строчкой ты в for цикле обходишь все строки матрицы, они же подмассивы массива  Matrix, просто 'a'. Делаем мы это 'n' раз.

Четвётрой строчкой ты инициализируешь массив(ы, мы в цикле) 'a', и следующей строчкой заполняешь уже его. Так же в for цикле. Всего в нём будет 'm' элементов.

Надеюсь решение правильное. Честно говоря у тебя вопрос очень странно поставлен.

Lvmadina
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

надо написать программу на языке С Вычислите таблицу значений выражения (x3+1)/(x-3)+x. Начальное и конечное значение вводит пользователь. Предусмотрите проверку корректности (начало меньше конца
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oduvanalex
nalekseeva62
IP1379
v79150101401
nikolavlad
yanermarina87
zybin41iz81
ocik1632933
far-yuliya128
Tarapovskaya
ksyusatom19
Leonidovich_Elena771
okykovtun31
Vladislav98
veronica1344