Эвелина
?>

РЕШЕНИЯ ТОЖЕ НУЖНЫ, 1. Определите значение переменной S после выполнения фрагмента программы: i:=2; S:=2; while i < 11 do begin i:= i + 3; S:= S + 2 * i; end; 2. Запишите значение переменной sum после выполнения фрагмента программы: sum:=2; for i:= 2 to 4 do sum:= sum + 3* i; 3. Запишите результат выполнения программы: var p, n: integer; begin p:= 2; for n:= 10 dowto 9 do p:= p * n; writeln (p); end

Информатика

Ответы

aleksvasin

Объяснение:

1. 50

2. 29

3. 180

1)

I=2

S=2

2<11, тогда i=2+3=5 s=2+2*5=12

5<11, тогда i=5+3=8, s=12+2*8=28

8<11, тогда I=8+3=11, s=28+2*11=50

11 не меньше 11, значит s=50

2)

Sum=2

I=2, sum=2+3*2=8

I=3, sum=8+3*3=17

I=4, sum=17+3*4=29

3)

p=2

n=10, p=2*10=20

n=9, p=20*9=180

                 

Shipoopi8
так:

                                          

                               Думаю тебе алгаритм ветвения,он состаит из вывода,условия,и начала,конца.

                                                 Если ошибся,поправьте.

                                                  Начало

                                

                                                 Вывод(указываем переменные,A,B.ну и т.д.)

 

               Да                               Условие(к примеру:A>=B)          Нет                                                                            

 

         Если х=A+B                                                                                Иначе х=A/B

 

                                               Ну и дальше вывод,и конец.

                                       Вывод

                                       

                                       Конец.

Простите,что данный алгаритм написан не достаточно хорошо,ну думаю вам

varvv15
Program prog;
uses crt;
var
a:array[1..100] of real;
m:integer;
s1, s2, s3, s4:real;

begin;
for m:=1 to 12 do
begin
     write('В месяц ',m,' температура t = ');
     readln(a[m]);
end;

s1:=(a[12]+a[1]+a[2])/3;
s2:=(a[3]+a[4]+a[5])/3;
s3:=(a[6]+a[7]+a[8])/3;
s4:=(a[9]+a[10]+a[11])/3;

writeln('Средняя температура зимних месяцев = ', s1:0:3);
writeln('Средняя температура весенних месяцев = ', s2:0:3);
writeln('Средняя температура летних месяцев = ', s3:0:3);
writeln('Средняя температура осенних месяцев = ', s4:0:3);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШЕНИЯ ТОЖЕ НУЖНЫ, 1. Определите значение переменной S после выполнения фрагмента программы: i:=2; S:=2; while i < 11 do begin i:= i + 3; S:= S + 2 * i; end; 2. Запишите значение переменной sum после выполнения фрагмента программы: sum:=2; for i:= 2 to 4 do sum:= sum + 3* i; 3. Запишите результат выполнения программы: var p, n: integer; begin p:= 2; for n:= 10 dowto 9 do p:= p * n; writeln (p); end
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

VadimovnaIgor
zsa100
tatyanaryzhkova
stsnab
Irina-Tunyan
alex07071
irschacha
Краева
Chikichev456
nikomuneskazhu60
MikhailovnaAnastasiya
zoyalexa495
zubritskiy550
Alena824
prostopo4ta29
▲