Адекватная версия:
PascalABC.NET
begin
var expr := Readstring();
expr.Split(' ')[0].Println;
end.
Версия "Нас так учили"
var
expression: string;
s_index: byte;
begin
s_index := 1;
readln(expression);
while expression[s_index] <> ' ' do begin
write(expression[s_index]);
s_index := s_index + 1;
end;
end.
Объяснение:
Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.
Поделитесь своими знаниями, ответьте на вопрос:
Имеется плата ArduinoUno. К пину платы А0 подключен датчик влажности почвы, а к пину номер 7 подключено реле, управляющее питанием помпы для полива растения. Напишите программу для среды Arduino IDE, выполняющую следующие функции: 1) контроллер измеряет влажность почвы и полученные данные одной строкой отправляет в монитор порта; 2) контроллер включает помпу для полива цветка на 1 минуту при снижении показаний датчика влажности грунта ниже 64.
Адекватная версия:
PascalABC.NET
begin
var expr := Readstring();
expr.Split(' ')[0].Println;
end.
Версия "Нас так учили"
var
expression: string;
s_index: byte;
begin
s_index := 1;
readln(expression);
while expression[s_index] <> ' ' do begin
write(expression[s_index]);
s_index := s_index + 1;
end;
end.
Объяснение:
Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.