info40
?>

Pascal Составить программу для построения таблицы значений x и y для функции у=-xcos(x) при изменении х в диапазоне [-3, 3] с шагом 0.3. В колонках должны быть n, х, у>0, у<0, где n - номер по порядку

Информатика

Ответы

cvetprint
begin (-30..30).Step(3).ForEach((x,i)->writeln((i+1):2,(x/10):7,(-x*cos(x/10)):10:2));end.

Пример работы:


Pascal Составить программу для построения таблицы значений x и y для функции у=-xcos(x) при изменени
sve707ta

а) Если адрессация 32-х разрядная, то число ячеек - 2^{32}.

б) Максимальный объмем адрессуемой памяти - 2^{32} = 4гб. Вспомните траблу с тем, что на 32-х разрядных ОС (которые задействуют проц в виртуальном режиме - могут использовать его как 32-х разрядный, если он даже 64-х) видимый максимальный объмем ОЗУ не больше этого предела, хоть пусть стоят плашки по 32гб.

в) Ну, если считать, что первый адрес - 0, то последний 2^{32} - 1


П.С. Число ячеек = объему памяти в байтах, так как можно адрессовать каждый байт - было сказано, что "при каждой операции... 32 бита данных", это говорит, что регистры тоже 32-х разрядные, но если вы видели какой-нибудь из языков ассемблера, то там можно обращаться к частям регистров, вплоть до размера части в 8 бит. Это на практике.


П.С.С. Сказано что проц теоретический, возможно, подразумевается, что ячейки не 1 байт, а 4 байта, т.е число ячеек в 4 раза меньше - 2^{30}. Выбирайте, что вам кажется более подходящим, препод вам известнее :)

Sadovskaya425

а) Если адрессация 32-х разрядная, то число ячеек - 2^{32}.

б) Максимальный объмем адрессуемой памяти - 2^{32} = 4гб. Вспомните траблу с тем, что на 32-х разрядных ОС (которые задействуют проц в виртуальном режиме - могут использовать его как 32-х разрядный, если он даже 64-х) видимый максимальный объмем ОЗУ не больше этого предела, хоть пусть стоят плашки по 32гб.

в) Ну, если считать, что первый адрес - 0, то последний 2^{32} - 1


П.С. Число ячеек = объему памяти в байтах, так как можно адрессовать каждый байт - было сказано, что "при каждой операции... 32 бита данных", это говорит, что регистры тоже 32-х разрядные, но если вы видели какой-нибудь из языков ассемблера, то там можно обращаться к частям регистров, вплоть до размера части в 8 бит. Это на практике.


П.С.С. Сказано что проц теоретический, возможно, подразумевается, что ячейки не 1 байт, а 4 байта, т.е число ячеек в 4 раза меньше - 2^{30}. Выбирайте, что вам кажется более подходящим, препод вам известнее :)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal Составить программу для построения таблицы значений x и y для функции у=-xcos(x) при изменении х в диапазоне [-3, 3] с шагом 0.3. В колонках должны быть n, х, у>0, у<0, где n - номер по порядку
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info6
guzelda19904850
Прошкин_Николай368
uisfbu7777733
pristav9
Александрович Андреевна
AndreevManaeva
Ingakazakova
Ахмедшина Трубников1249
mvv-155
AOS2015
muzaffarovich-Sergei1777
zamkova836
gbnn90
Lebedeva1577