superkiosk249
?>

В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной b после выполнения алгоритма: а:=7 b:=3 а:=2*а+6*b b:=a/8 Напишите сюда одно целое число — значение переменной b.

Информатика

Ответы

murza2007

4

Объяснение:

a:=2*7+6*3=14+18=32

b:=32/8=4

Kochereva-Sergei
//PascalABC.NET
//Дан целочисленный массив из 40 элементов. Элементы массива могут
//принимать значения от -10000 до 10000. Написать алгоритм, который
//находит и выводит среднее арифметическое всех отрицательных элементов
//массива, оканчивающихся цифрой 7. Гарантируется, что хотя бы один
//такой элемент в массиве есть. Исходные данные объявлены так, как
//показано ниже. Запрещается использовать переменные, не описанные
//ниже, но разрешается не использовать часть из них.

const
    N = 40;
var
    //a : array[1..N] of integer;
    i, s, r, x : integer;
    sr: real;
begin
    //Для любителей заполнять вручную:
    //for i := 1 to 40 do readln(a[i]);
   
    //Заполним массив 40-ка случайными значениями
    var a := ArrRandomInteger(N+1, -10000, 10000);
    //Гарантировано разместим число, оканчивающееся на 7
    a[Random(0,40)] := -10 * Random(0,999) - 7;
    //Уберем лишний элемент, созданный автоматически
    a[0] := 0;
    //Напечатаем массив
    a.println;
    writeln('----------------');
    //Просмотрим весь массив и найдя отрицательное, оканчивающееся на 7
    //число, учтём его
    foreach i in a do
        if (i < 0) and (i mod 10 = -7) then begin
            r += i; s += 1; write(i,' ')
        end;
    //Выведем среднее арифметическое
    writeln('Ср.ар: ',r/s)
end.

Дан целочисленный массив из 40 элементов. элементы массива могут принимать значения от -10000 до 100
volkovaoksana19806037
Версия языка: PascalABC.Net 3.2, сборка 1437 от 03.05.2017

1. Сохраняем текст модуля в файле garnaga.pas и выполняем компиляцию (Ctrl+F9)

unit garnaga;

interface

type Mass2d=array [,] of integer;

function GetMass(rand:boolean:=true):Mass2d;

function SumDiag(a:Mass2d):integer;

implementation

function GetMass(rand:boolean):Mass2d;
begin
  var n:=ReadInteger('Количество строк/столбцов в массиве:');
  if rand=true then begin
    var a:=ReadInteger('Минимальное значение для заполнения:');
    var b:=ReadInteger('Максимальное значение для заполнения:');
    Result:=MatrRandom(n,n,a,b)
    end
  else begin
    Writeln('Вводите элементы массива:');
    Result:=ReadMatrInteger(n,n)
    end
end;

function SumDiag(a:Mass2d):integer;
begin
  Result:=0;
  var n:=a.RowCount-1;
  for var i:=0 to n do Result+=a[i,i]+a[i,n-i];
  if n.IsEven then begin
    n:=n div 2;
    Result-=a[n,n]
    end
end;

end.

2. Создаем новый файл и помещаем в него программу, использующую созданный модуль

uses garnaga;

begin
  var a:=GetMass; a.Println; Writeln;
  var b:=GetMass; b.Println; Writeln;
  var c:=GetMass(false); Writeln;
  Writeln('Sдиаг=',SumDiag(a)+SumDiag(b)+SumDiag(c))
end.

3. Запускаем программу на выполнение.

Пример работы:
Количество строк/столбцов в массиве: 4
Минимальное значение для заполнения: -20
Максимальное значение для заполнения: 35
   4 -14 -14  26
  26  -6  12  22
  13  10 -20  26
  -3  22  14  -4

Количество строк/столбцов в массиве: 5
Минимальное значение для заполнения: 0
Максимальное значение для заполнения: 50
  13  48   5  12   2
  43  31  45  35  23
  36  30   6  47  42
  11   8  29  36  39
  11  33  14  48  29

Количество строк/столбцов в массиве: 3
Вводите элементы массива:
1 6 2
8 3 4
7 0 5

Sдиаг=208

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной b после выполнения алгоритма: а:=7 b:=3 а:=2*а+6*b b:=a/8 Напишите сюда одно целое число — значение переменной b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lusiarko65
АлександровнаВладимирович1424
egoryandiana3727283
andreevaalisa
majorovnatalya5
Korikm
yuliyastatsenko3894
vladimirdoguzov
sv455umarketing74
losevev5619
energycomplect5914
Антон
mikhailkirakosyan
TatiyanaBe20135263
krisrespect