Антон
?>

Задача 1. Написать программу которая присваивает случайное значение сторонам равнобедренного треугольника. А после находит его площадь через формулу с S=ah

Информатика

Ответы

Мирзоев Денис
Var
  mini, min, n, i: integer;

begin
  i := 1; {порядковый номер введенного с клавы числа}
  readln(n); {считываем число в клавиатуры}
  min := n; {присваеваем минимуму первое введенное число. Если будет введено одно число то оно и есть минимум}
  mini := i; {присваеваем порядковый номер минимума}
 
  repeat{повторяем}
    i := i + 1; {порядковый номер введенного с клавы числа}
    readln(n); {считываем число в клавиатуры}
    if (n <> 0) and (min > n) then begin {если введенное число меньше минимума, то заменяем минимум}
      min := n; {присваеваем минимуму число}
      mini := i;{присваеваем порядковый номер минимума}
    end;
  until n = 0;{до тех пор пока n=0}
 
  writeln('index = ', mini);
end.

Что еще не понятно?

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача 1. Написать программу которая присваивает случайное значение сторонам равнобедренного треугольника. А после находит его площадь через формулу с S=ah
Ваше имя (никнейм)*
Email*
Комментарий*