Рогов1996
?>

Даны два массива x=(x1, x2, x3, х4), у=(у1, у2, у3, у4 Написать программу нахождения суммы этих массивов. Pascal

Информатика

Ответы

ckati
Поиск простых делителей числа:

var i,j,n:longint;
    f:boolean;
begin
 writeln('Введите число');
 readln(n);
  if n<2 then writeln('Простых делителей нет')
  else
   begin
    write('Число ',n,' ','= 1');
    for i:=2 to n do
     if n mod i=0 then
      begin
       f:=true;
       j:=2;
       while f and(j<=round(sqrt(i/2)))do
        begin
         if i mod j=0 then f:=false
         else j:=j+1;
        end;
      if f then write('*',i);
     end;
   end;
end.

Тестовое решение:

Введите число
2345
Число 2345 = 1*5*7*35*67
krikatiy
Алгоpитм — точное и понятное пpедписание исполнителю совеpшить последовательность действий, направленных на решение поставленной задачи.

Основные свойства алгоритмов:

Понятность для исполнителя
Дискpетность (прерывность, раздельность) — алгоpитм должен пpедставлять пpоцесс pешения задачи как последовательное выполнение пpостых (или pанее опpеделенных) шагов (этапов).
Опpеделенность — каждое пpавило алгоpитма должно быть четким, однозначным и не оставлять места для пpоизвола.
Pезультативность — это свойство состоит в том, что алгоpитм должен пpиводить к pешению задачи за конечное число шагов.
Массовость. Алгоpитм pешения задачи pазpабатывается в общем виде.
Формы представления алгоритмов.

• словесная (записи на естественном языке);
• графическая (изображения из графических символов);
• псевдокоды (полуформализованные описания алгоритмов на условном алгоритмическом языке;
• программная (тексты на языках программирования).

Словесный записи алгоритмов представляет собой описание последовательных этапов обработки данных.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два массива x=(x1, x2, x3, х4), у=(у1, у2, у3, у4 Написать программу нахождения суммы этих массивов. Pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei_Olga658
Голосова-Лобанов1555
Rafigovich1267
Некрасов Валентина1097
LYuBOV
omigunova39
Марина1101
Маринина_Елена
extremhunter
Lapushkina
milanparipovic864
Кочугурова
Ионов202
Irinalobanowa
yanermarina87