Поделитесь своими знаниями, ответьте на вопрос:
написать программу на си задача: Дана числовая последовательность чисел А1, А2, n, где n количество чисел в последовательности. Составить программу определяющую: сумму всех нечетных чисел в последовательности.
var c, s, n, k : integer;
x,d :longint;
begin
writeln('введите x');
readln (x);
k := 0; //количество четных цифр в числе
while x > 0 do //пока х не равен нолю
begin
if (x mod 2) = 0 then k := k + 1; //проверяем четна ли последняя цифра числа
//+1 к кол-ву четных цифр
x := x div 10; //сокращаем на один знак и повторяем операцию
end;
if k >= 2 then
writeln('Да') //если кол-во четных цифр больше 2
//выводим 2, иначе не выводим ничего
end.
/* Вот написал сам, но то что пытался сделать ты не понял */