docvet4
?>

Составить программу, которая создает одномерный целочисленный массив, состоящий из 15 элементов, инициализирует его и выводит на печать. CC+

Информатика

Ответы

ritckshulga20112

Объяснение:

#include <stdio.h>

#include <stdlib.h>

int main()

{  

int i;

int arr[15];

for(i=0; i<15; i++)

 {

  scanf("%d", &arr[i]);

 }

for(i=0; i<15; i++)

 {

  printf("%d ", arr[i]);

 }  

return 0;

}

Роман1406
Windows  – без обновления операционной системы, вы и не почувствуете всех обновлений. мы рекомендуем  установить windows 8, так как она выполнена по всем современным меркам.монитор  – это первое на что мы обращаем внимание, сидя за компьютером, и чем он будет больше и красивее, тем больше положительных эмоций вы получите от обновления пк. рекомендуем для этого прочесть статью: «как выбрать монитор для компьютера». в подключении монитора думаем, что вопросов не возникнет.клавиатуру и мышь  – какое же внешнее обновление компьютера без замены  мышкиили  клавиатуры? ! обязательно выберите себе новые манипуляторы! коробку системного блока  – даже если у вас нет денег (или желания) обновлять все комплектующие компьютера (например, и этими вы довольно), то просто обновите коробку системного блока на современную. в этом случае все вокруг подумают, что вы обновили своё пк полностью! если нет навыков сбора компьютера – доверьте это дело профессионалам, таким как на masterservis24.ru! акустика  – последним штрихом в создании нового образа компьютера будет новое звучание и новый вид колонок для компьютера, чтобы вы не только видели обновленный компьютер, но и слышали его. кстати колонки можно просто заменить  новыми и хорошими наушниками для компьютера. если вас устраивает внешний вид пк, а больше интересует скорость его работы, то вам нужно выполнить обновление следующих деталей: процессор  – главная деталь всего компьютера, так как именно от мощности этого устройства зависит быстрота работы всей системы. помните, что  выбирать процессор для компьютера нужно правильно  (о чём мы уже писали ранее).материнская плата  – её нужно менять по нескольким причинам: во-первых, каждый из процессоров подходит только к определенным моделям «материнки». во-вторых, вам на материнской плате может не хватать слотов для дополнительного озу или второй видеокарты. о том,  как выбрать материнскую плату  мы писали ранее. устанавливать её самостоятельно не советуем, лучше попросить о .оперативное запоминающее устройство (озу)  – его также следует обновлять, однако если не хватает денег, то лучше выбрать более мощный процессор, чем много озу, ведь память всегда можно добавить самостоятельно и даже не вызывая мастера.жесткий диск  – скорости в работе компьютера он вряд ли прибавит (если только это не ssd диск), зато у вас появиться масса свободного места для разных файлов. перед тем, как купить жесткий диск, рекомендуем прочесть статью  как его выбрать, а также  как правильно устанавливать жесткий диск.видеокарта  – обновлять её нужно только в том случае, если она вышла из строя (шумит, например) или вы хотите играть в новые компьютерные игры, которые требуют более нового «железа».блок питания  – о том,  как выбрать блок питания  мы писали совсем недавно, и его замена будет для вас больше вынужденной, так как новые комплектующие устройства всегда более требовательны к энергии. новый блок питания не даст сгореть компьютеру и обеспечит его стабильную работу.
djikia88
//Dev-C++ 4.9.9.2

//а
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int m=0;
         cout<<"Enter m:";
         cin>>m;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=0;i<m;i++)
          arsub[i]=ar[i];
         for(int i=0;i<n-m;i++)
          ar[i]=ar[i+m];
         for(int i=0;i<m;i++)
          ar[i+(n-m)]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}

//б
#include <iostream>
using namespace std;

const int n=10;

int main(){
         int ar[n];
         int arsub[n];
         int k,k1=0;
         cout<<"Enter k:";
         cin>>k;
         cout<<"Enter array:"<<endl;
         for(int i=0;i<n;i++)
          cin>>ar[i];
         for(int i=n-k;i<n;i++){
          arsub[k1]=ar[i];k1++;}
         for(int i=n;i>=k;i--)
          ar[i]=ar[i-k];
         for(int i=0;i<k;i++)
          ar[i]=arsub[i];
         cout<<"Final array"<<endl;
         for(int i=0;i<n;i++)
          cout<<ar[i]<<' ';
        cin.get();
        cin.get();
 return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая создает одномерный целочисленный массив, состоящий из 15 элементов, инициализирует его и выводит на печать. CC+
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei1805
margusha1974
алексеевич810
andruhovich
Olga1509
Yumashev
notka19746
pravovoimeridian
evrotrastop64
festjob
КристинаАлександр
Wlad967857
paninsv
BrezhnevaKoidula
Volkov
▲