Lenuschakova1982316
?>

ПИТОН! ОТ Обратное числоВ этой задаче нужно ответить на 1≤≤1051≤t≤105 запросов. Каждый запрос состоит из двух целых чисел 2≤≤1092≤p≤109 и 0<<0<a<p, число p является простым. На каждый запрос нужно вывести в отдельной строке целое число 0<<0<b<p такое, что (⋅−1) ⋮ (a⋅b−1)⋮p.Входные данныеВ первой строке дано целое число t — количество запросов.В следующих t строках даны по два числа pi и ai, =1, …, i=1, …, t.Выходные данныеВыведите t целых чисел (каждое число в отдельной строке) — ответы на запросы.ПримерыВводВывод45 15 25 35 41324ОграниченияВремя выполнения: 5 секунд

Информатика

Ответы

Galina-Marat1096

b = []

for x in range(int(input())):

   a = list(map(int, input().split()))

   b.append(pow(a[1], a[0] - 2, a[0]))

print('\n'.join(map(str, b)))

Объяснение:

Эта программа зашла.

Александра Викторович531
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44
infooem

1. Берілген нүктелер арқылы өтетін түзудің теңдеуін жазыңыз: А(2;1) В(-1;2). [2 ұпай]

2. Шеңбердің берілген теңдеуі бойынша оның центрінің координаталары мен радиусын табыңыз: (х-4)2 +(у+8)2 =36 [1 ұпай]

3. нүктелері берілген.

a) төбелерінің координаталары бойынша салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [3 ұпай]

c) түрін анықтаңыз (теңқабырғалы, теңбүйірлі, тікбұрышты); [2 ұпай]

d) берілген үшбұрыштың ауданын есептеңіз. [2 ұпай]

4. Төбелері А (1;-1) В (0;1) С (4;3) және Д (5;1) нүктелері болатын төртбұрыштың тіктөртбұрыш болатынын дәлелдеп, оның ауданын табыңыз. Ол үшін:

a) төбелерінің координаталары бойынша сызбасын салыңыз; [1 ұпай]

b) қабырғаларының ұзындықтарын табыңыз; [4 ұпай]

c) диагональдарын анықтап, дәлелдеңіз; [2 ұпай]

d) тіктөртбұрыштың ауданын есептеңіз. [2 ұпай]

Объяснение

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПИТОН! ОТ Обратное числоВ этой задаче нужно ответить на 1≤≤1051≤t≤105 запросов. Каждый запрос состоит из двух целых чисел 2≤≤1092≤p≤109 и 0<<0<a<p, число p является простым. На каждый запрос нужно вывести в отдельной строке целое число 0<<0<b<p такое, что (⋅−1) ⋮ (a⋅b−1)⋮p.Входные данныеВ первой строке дано целое число t — количество запросов.В следующих t строках даны по два числа pi и ai, =1, …, i=1, …, t.Выходные данныеВыведите t целых чисел (каждое число в отдельной строке) — ответы на запросы.ПримерыВводВывод45 15 25 35 41324ОграниченияВремя выполнения: 5 секунд
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chistova-Dmitrii1162
bronco-s
Petrushin482
waspmoto6188
nash-crimea2019
Демидова Красноцветов
Solovetzmila
Алиференко_Елена342
shoko91
zaha98
whitewhit90
yusovd291
mkovanov
annakuzina2023
vakhitov100961