Вадим-Рашад323
?>

1) Часть программы , которую компилятор будет игнорировать-это ? 2)а- целочисленная переменная . Чему равно а после выполнения следующей операции ? а:= 10 mod 2 3)а- целочисленная переменная . Чему равно а после выполнения следующей операции ? a:= 12 div 6 4) Как называется файл для регистрации других файлов ? 5)Чему равно логическое выражение при А=0, В=0, С=1? (Если (не В или С) то ( С или неВ и А)) или ((неА или В ) и С) 6) Рассчитайте среднюю информацию , содержащуюся в одной букве алфавита со следующим распределением вероятностей использования букв: А: 1/2 , В:1/8, С:1/16 , D: 1/16 7)Как комплексную дисциплину информатика определяет ее -особенности подхода -прикладной характер -фундаментальный характер -особенности методов познания (Несколько вариантов ответа )

Информатика

Ответы

Irina_Nikolai

1 - True/False

2 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания ложны.

3 - Конъюнкция

4 - X И Y И Z

5 - OR

6 - 1. Инверсия;

2. Конъюнкция;

3. Дизъюнкция;

4. Импликация;

5. Эквивалентность.

7 - логическая операция, которая преобразует исходное высказывание в новое, значение которого противоположно исходному.

8 - Импликация

9 - логическая операция, которая объединяет два высказывания в одно новое, которое будет являться истинным тогда и только тогда, когда оба исходных высказывания истинны

10 -  Конъюнкция

11 - ?

12 - ?

Объяснение:

RozaAsadullina

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

var f1,f2,f3:text;

   n,i,a,b:integer;

begin

//создадим исходные файлы, можно вынести в отдельную программу

//или создать файлы вручную

randomize;

assign(f1,'f1.txt');

rewrite(f1);

assign(f2,'f2.txt');

rewrite(f2);

write('Сколько чисел ввести в первый файл n=');

readln(n);

writeln('Содержание файла f1:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f1,' ',a);

 write(' ',a);

end;

writeln;

write('Сколько чисел ввести во второй файл n=');

readln(n);

writeln('Содержание файла f2:');

a:=1;

for i:=1 to n do

begin

 a:=a+random(5);

 write(f2,' ',a);

 write(' ',a);

end;

writeln;

reset(f1);

reset(f2);

assign(f3,'f3.txt');

rewrite(f3);

//если не конец файла, то читаем числа иначе создаем барьер из

//максимально возможного целого числа

if not eof(f1) then read(f1,a) else a:=maxint;

if not eof(f2) then read(f2,b) else b:=maxint;

while (a<maxint) or (b<maxint) do//пока оба файла не кончились

begin

 if (a<=b) and (a<maxint) then //если 1<=2

  begin

   write(f3,' ',a);//1 пишем в файл 3

   if not eof(f1) then read(f1,a) else a:=maxint;//если не конец 1,

                                                 //то читаем следующее , иначе барьер

 end

 else if b<a then //иначе если 2<1 то же но со 2 файлом

  begin

   write(f3,' ',b);

   if not eof(f2) then read(f2,b) else b:=maxint;

 end;

end;

reset(f3);//смотрим что получилось

writeln('Слияние файлов:');

while not eof(f3) do

begin

 read(f3,a);

 write(' ',a);

end;

close(f1);

close(f2);

close(f3);

end.

Объяснение:

Вроде бы так, я не слишком в этом хорош.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Часть программы , которую компилятор будет игнорировать-это ? 2)а- целочисленная переменная . Чему равно а после выполнения следующей операции ? а:= 10 mod 2 3)а- целочисленная переменная . Чему равно а после выполнения следующей операции ? a:= 12 div 6 4) Как называется файл для регистрации других файлов ? 5)Чему равно логическое выражение при А=0, В=0, С=1? (Если (не В или С) то ( С или неВ и А)) или ((неА или В ) и С) 6) Рассчитайте среднюю информацию , содержащуюся в одной букве алфавита со следующим распределением вероятностей использования букв: А: 1/2 , В:1/8, С:1/16 , D: 1/16 7)Как комплексную дисциплину информатика определяет ее -особенности подхода -прикладной характер -фундаментальный характер -особенности методов познания (Несколько вариантов ответа )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Полковников_Милана
andreanikin
Семеновна-Павел
turovvlad
Яковчук1911
Дмитрий_Владимирович1162
Микроволновые системы что это​
fialkaflowers77
Shtorm-Shoe
annino
extremhunter
lenapopovich556510
pravovoimeridian
Elen-ti81459
yanva
Гарик383