1. В массиве С(36) найти среднее арифметическое значение положительных элементов. написать программу на qbasic и составить блок схему желательно в ворде
#include <iostream> #include <vector> using namespace std;
int main() { unsigned short int n; cout << "n = "; cin >> n; vector<int> a; int in, avg, s = 0, c = 0; for (int i = 0; i < n; ++i) { cout << "a[" << i << "] = "; cin >> in; a.insert(a.end(), in); if (i % 2 == 1) { s += a.back(); c++; } } avg = (int) s / c; cout << "Среднее арифметическое элементов на нечётных позициях: " << avg; return 0; }
adminaa
23.08.2022
Точная задача по Техническому Заданию: var x,y:integer; begin writeln('введите два числа'); readln(x); readln(y); if (x<1000000001) and (y<1000000001) and (x>0) and (y>0) then writeln('сумма чисел =',x+y) else writeln('диапазон чисел неверный'); end.
Если вдруг вам поверит учитель, можете перевыполнить поставленную задачу: var x,y:integer; s:string; begin randomize; writeln('взять ли числа случайными? ответ да или нет'); readln(s); if (s='да') or (s='Да') or (s='ДА') or (s='дА') then begin x:=random(1000000000); y:=random(1000000000); writeln('сумма чисел =',x+y); writeln('произведение чисел =',x*y); end else begin writeln('введите два числа'); readln(x); readln(y); writeln('сумма чисел =',x+y); writeln('произведение чисел =',x*y); end; end.
#include <vector>
using namespace std;
int main() {
unsigned short int n;
cout << "n = ";
cin >> n;
vector<int> a;
int in,
avg,
s = 0,
c = 0;
for (int i = 0; i < n; ++i) {
cout << "a[" << i << "] = ";
cin >> in;
a.insert(a.end(), in);
if (i % 2 == 1) {
s += a.back();
c++;
}
}
avg = (int) s / c;
cout << "Среднее арифметическое элементов на нечётных позициях: "
<< avg;
return 0;
}