Дил1779
?>

Нужно написать программу в системе Си. Опишите все полностью от начала и до конца, а то я глупый немного) Найти объем конуса по радиусу и высоте. Предусмотреть проверку правильности ввода данных (они должны быть больше нуля

Информатика

Ответы

murza2007
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  Range(1,50,2).Tabulate(x->sqrt(x)).Println(NewLine)
end.

Результат
(1,1)
(3,1.73205080756888)
(5,2.23606797749979)
(7,2.64575131106459)
(9,3)
(11,3.3166247903554)
(13,3.60555127546399)
(15,3.87298334620742)
(17,4.12310562561766)
(19,4.35889894354067)
(21,4.58257569495584)
(23,4.79583152331272)
(25,5)
(27,5.19615242270663)
(29,5.3851648071345)
(31,5.56776436283002)
(33,5.74456264653803)
(35,5.91607978309962)
(37,6.08276253029822)
(39,6.2449979983984)
(41,6.40312423743285)
(43,6.557438524302)
(45,6.70820393249937)
(47,6.85565460040104)
(49,7)
Алексей Ксения
Var a,b:longint;
function sum (n:integer):integer;
  var s:integer;
  begin
     s:=0;
     while (n<>0) do
       begin
         s:=s+n mod 10;
         n:=n div 10;
       end;
     sum:=s; 
  end;
  begin
    write ('A = ');
    readln (a);
    write ('B = ');
    readln (b);
    if sum(a) > sum(b) then
       writeln ('Сумма цифр 1ого числа больше на ',sum(a)-sum(b))
    else if sum(b) > sum (a) then 
       writeln ('Cумма цифр 2ого числа больше на ',sum(b)-sum(a))
    else writeln ('Сумма цифр 1ого числа равна сумме цифр 2ого числа');
    readln;
  end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу в системе Си. Опишите все полностью от начала и до конца, а то я глупый немного) Найти объем конуса по радиусу и высоте. Предусмотреть проверку правильности ввода данных (они должны быть больше нуля
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sergeychelyshev197618
Михайловна-Гусева350
Дмитрий192
iservice38
Volodka
Андрей628
mv7095
elenasnikitina84
Эдуардович873
ShALIGINA
smint056950
memmedovallahverdi0239
Golubovskayairina
aregaa
menesmir