Юлия Соколовская1568
?>

Напишіть програму, яка оприділяє, скільки буде коштувати вхід для людей віком: - до 4 років - до 18 років - і старше Виведіть результат на екран. мова програмування Python

Информатика

Ответы

izykova22
На с++.
#include <string.h>#include <locale.h>#include <math.h>#include <stdio.h>#define LANG 1 //Язык: 0 - английский; 1 - русскийsize_t kA = 0, ka = 0;int delta = (LANG) ? 'а' - 'А' : 'a' - 'A';void iter(char[], void(*)(char*), void(*)(char*));void incA(char* z = 0) { kA++; }void inca(char* z = 0) { ka++; }void changeA(char* ch);void changea(char* ch);int main() { setlocale(LC_ALL, "Russian"); char str[] = "ПихАЙ СЮДА ИСХОднУЮ СТРОКУ СИмволов"; iter(str, incA, inca); iter(str, changeA, changea); printf(str); return 0;}void iter(char str[], void(*trued)(char*), void(*falsed)(char*)) { for (size_t i = 0; i < strlen(str); ++i) { if (str[i] >= 'A' && str[i] <= 'Z' || str[i] >= 'А' && str[i] <= 'Я') trued(str+i); if (str[i] >= 'a' && str[i] <= 'z' || str[i] >= 'а' && str[i] <= 'я') falsed(str + i); }}void changeA(char* ch) { if (kA < ka) { *ch = *ch + delta; }}void changea(char* ch) { if (kA > ka) { *ch = *ch - delta; }}
Написать программу на си дан текст. определить, каких букв в нем больше: строчных или прописных. есл
Larisa-0888716
#include <iostream>
#include <algorithm>
#include <vector>using namespace std;bool Has(const vector<int> &primeNumbers, int value)
{
  bool has = false;
  for (int prime_number : primeNumbers)
  {
    if (value % prime_number == 0)
    {
      has = true;
    }
  }
  return has;
}vector<int> GetPrimeNumbers(int i)
{
  vector<int> primeNumbers= { 2, 3 };
  for (int j = 4;j < i;j++)
  {
    if (!Has(primeNumbers, j))
    {
      primeNumbers.push_back(j);
    }
  }
  return primeNumbers;
}int main()
{
  int n;
  cin >> n;
  vector<int> prime_numbers = GetPrimeNumbers(n);
  for (int prime_number : prime_numbers)
  {
    cout << prime_number << endl;
  }
  cin >> n;
  return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишіть програму, яка оприділяє, скільки буде коштувати вхід для людей віком: - до 4 років - до 18 років - і старше Виведіть результат на екран. мова програмування Python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вишняков997
Иванович-Васильевна1153
clubgarag701
bondarev05071962
Поликарпова-Мазурова
versalmoda2971
Александра Викторович531
Ушакова1902
olga0909196323
schernov
mon84
skalegin68
cvetprint
Akolomaeva4
MDubovikov73