lshimina65
?>

Язык Python3 Простое число По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число. Входные данные Во входном файле находится одно натуральное число K. Выходные данные В выходной файл выведите K-е простое число. Примеры Ввод: 3 Вывод: 5 Ввод: 1 Вывод: 2

Информатика

Ответы

naromanova

Ну, можно так:

Объяснение:

def prostoe(chislo):

   a = True

   for i in range(2, chislo//2 + 1):

       if chislo % i == 0:

           a = False

           break

   return a

k = int(input("Введите число, не превосходящие 100000: "))

schetchic = 1

a = 2

while k >= schetchic:

   if prostoe(a):

       prostoi = a

       schetchic += 1

   a += 1

print(prostoi)

ngz55
Животные потребляют готовые вещества (гетеротрофы), растения производят их сами (автотрофы)... есть различия в строении клетки...

Животные отличаются от растений развитием при для схватывания пищи.

Наиболее существенное различие между животными и растениями в питания. Зеленые растения получают из внешней среды одни лишь неорганические вещества: воду, минеральные соли из почвы и углекислый газ из воздуха. Из этих неорганических веществ в клетках зеленого растения создаются органические вещества. Такой питания называют растительным или автотрофным.

Ни одно животное не может жить за счет неорганических веществ и создавать из них в своем теле органические вещества. В отличие от растений животным необходимы для питания сложные органические вещества: белки, жиры и углеводы, которые они получают, поедая растения или других животных. Такой тип питания называется животным или гетеротрофным.
prostopo4ta29
Шупашкар Чăваш Республикин тĕп хули. Шупашкарта пĕтĕмпе 460,2 пин çын (2002 çулхи халăх çыравĕ тăрăх) пурăнать. Шупашкар Чулхулапа Хусан хулисем хушшинче, Атăл юханшывăн сылтăм çыранĕнче вырнаçнă. Шупашкар виçĕ района пайланать: Калинин районĕ, Ленин районĕ, Мускав районĕ тата Атăл лешьенчи çĕр тытăмĕ. Шупашкартан инçех мар хула-спутникĕ Çĕнĕ Шупашкар вырнаçнă. Унта пĕтĕмпе 125 пин çын пурăнать. Шупашкар кунĕ: çурла уйăхĕн виççĕмĕш вырсарникунĕ. Шупашкар хулинчен аякрах мар Атăл тăрăх кайсан Çĕнĕ Шупашкар, Сĕнтĕрвăрри, Куславкка хулисем вырнаçнă.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык Python3 Простое число По введённому натуральному числу K, не превосходящему 100000, выдать K-е по счёту простое число. Входные данные Во входном файле находится одно натуральное число K. Выходные данные В выходной файл выведите K-е простое число. Примеры Ввод: 3 Вывод: 5 Ввод: 1 Вывод: 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

valerii_Georgievna915
Меладзе_Владимир1695
dksvetlydir
lestnica
avetisov-84850
akrivoz
kirill76536
teregorka1977205
dddddd68
kalterbrun
annanechaeva567
Gera8061
Dmitriy793
shchepinasm
Lidburg
▲