krtatiana69
?>

решить задачу по информатике Надо составить программу, вычислить и напечатать площадь ромба при значении диагоналей d1=15, 9 и d2 в 3 раза меньше d1.

Информатика

Ответы

Imarmy67

Объяснение:

сделай в проге

Введите д1 и д2.

2 С: = д1*д2/2.

3. Пиши на экран (С).

Серопян
Ll - long long

dp[i] = dp[i-1] + dp[i-2] + dp[i-5] + dp[i-10];
ll dp[666];
dp[0] = 1;
for(int i=0;i<=64;i++)
{
dp[i+1]+=dp[i];
dp[i+2]+=dp[i];
dp[i+5]+=dp[i];
dp[i+10]+=dp[i];
cout << i << ": " << dp[i] << endl;
}
это если порядок важен, то есть 2 + 1 != 1 + 2, тогда ответ
489475342266653, наверное
а иначе 644

ll ans=0;
for(int i=0;i<10;i++) // 10
{
for(int j=0;j<20;j++) // 5
{
for(int k=0;k<50;k++) // 2
{
ll now = i*10 + j*5 + k*2;
if(now<=64) ans++;
}
}
}
cout << ans;
sigidinv
Обозначим P,Q,A утверждение что х принадлежит соответствующему отрезку
¬А отрицание А, то есть х не принадлежит А
перепишем и упростим исходную формулу
P→((Q∧¬A)→P)
известно что X→Y=¬X∨Y (доказывается просто, например через таблицу истинности)
тогда:
P→(¬(Q∧¬A)∨P)
раскроем скобку ¬(Q∧¬A) с закона де Моргана (стыдно их не знать, если что это такие же основы как и таблицы истинности)
P→(¬Q∨¬¬A∨P) = P→(¬Q∨A∨P) = ¬P∨¬Q∨A∨P
¬P∨P=1 то есть всегда истинно и 1∨Х=Х значит ¬P и P можно убрать
остается ¬Q∨A
Значит х либо принадлежит А либо не принадлежит Q
для выполнения этого условия необходимо чтобы все значения Q принадлежали А, тогда минимальное А совпадает с Q
ответ А=[40,77]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачу по информатике Надо составить программу, вычислить и напечатать площадь ромба при значении диагоналей d1=15, 9 и d2 в 3 раза меньше d1.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

peresvetoff100015
terehin863
Vasilevna_Utenkova651
Aleksandrovna Kolesnik1764
Анастасия Елена
cheremetdiana
qwe54344
Елена Васильева839
delo1005
voen-torg
Мария
Sharap
vgolentsova
НосовЖелиховская
Bogataya Vladimir318