Николаевич-Анатольевич599
?>

НА ЯЗЫКЕ ПАСКАЛЬ РЕШИТЬ Вася еще не ходит в школу и только учиться считать. Старший брат Васи - Петя уже первоклассник и даже знает про отрицательные числа и, уж тем более, умеет числа складывать(правда, пока только целые Но вот про существование 0, Петя забыл. Однако, кроме математики, Петя увлекается программированием и попросил вас написать ему программу для сложения и вычитания целых чисел без учета 0( то есть ряд целых чисел выглядит так: ..., −3, −2, −1, 1, 2, 3, ...). Формат ввода Первая строка входных данных содержит число N. Вторая строка содержит число M. Формат вывода Программа должна вывести одно целое число - сумму введенных чисел N и M.

Информатика

Ответы

barinovmisha2013

решение на фото .. ......


НА ЯЗЫКЕ ПАСКАЛЬ РЕШИТЬ Вася еще не ходит в школу и только учиться считать. Старший брат Васи - Петя
Рожнов

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
Reznikova1075

Код:

using System;

namespace WordsCounter

{

   class Bishop

   {

       private int x, y;

       public Bishop(int x, int y)

       {

           this.x = x;

           this.y = y;

       }

       public bool CanIAttackIt(int x, int y)

       {

           return Math.Abs(x - y) == Math.Abs(this.x - this.y);

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           var x0 = int.Parse(Console.ReadLine()!);

           var y0 = int.Parse(Console.ReadLine()!);

           var x = int.Parse(Console.ReadLine()!);

           var y = int.Parse(Console.ReadLine()!);

           Console.WriteLine((new Bishop(x0, y0)).CanIAttackIt(x, y));

       }

   }

}


На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг
На шахматной доске в клетке с координатами x1, y1 находится слон. Определить, сможет ли он убить фиг

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

НА ЯЗЫКЕ ПАСКАЛЬ РЕШИТЬ Вася еще не ходит в школу и только учиться считать. Старший брат Васи - Петя уже первоклассник и даже знает про отрицательные числа и, уж тем более, умеет числа складывать(правда, пока только целые Но вот про существование 0, Петя забыл. Однако, кроме математики, Петя увлекается программированием и попросил вас написать ему программу для сложения и вычитания целых чисел без учета 0( то есть ряд целых чисел выглядит так: ..., −3, −2, −1, 1, 2, 3, ...). Формат ввода Первая строка входных данных содержит число N. Вторая строка содержит число M. Формат вывода Программа должна вывести одно целое число - сумму введенных чисел N и M.
Ваше имя (никнейм)*
Email*
Комментарий*