novocherkutino7
?>

PYTHON Дано трехзначное число а. Определить: а) является ли произведение его цифр меньше числа а; б) кратна ли 5 сумма его цифр.

Информатика

Ответы

Dmitrii_Shamilevich2019

a = int(input())

p = 1

for i in tuple(str(a)):

 p *= int(i)

print('А) Да' if p > a else 'А) Нет.')

print('Б) Да.' if sum(map(int, tuple(str(a % 5 == 0 else 'Б) Нет.')

million2003

Программа:

Python:

1. Напишите программу, которая на вход получает 50 случайных чисел и находит в массиве количество элементов, делящихся на 7.

from random import randint

arr = [randint(-50,50) for i in range(50)]

j = 0

for i in arr:

  if i % 7 == 3:

     j += 1

print(arr, '\n', j, 'чисел делится на 7')

2. Написать программу, которая на вход получает 50 случайных чисел и находит среднее арифметическое всех элементов массива, которые делятся на 2 и заканчиваются на 2.

from random import randint

arr = [randint(-50,50) for i in range(50)]

j = k = 0

for i in arr:

  if i % 10 == 2 and i % 2 == 0:

     j += i

     k += 1

print(arr, '\nСреднее арифметическое чисел, которые делятся на 2 и заканчиваются на 2:', j / k)

Юрий197
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace СтрокаЧастота
{   
class Program   
{       
static void Main(string[] args)       
 {           
Char[] alf = "".ToArray();           
 int[] k = new int[66];           
string s = "Строка является объектом типа Строка, значением которого является текст. По сути, текст хранится в виде последовательной доступной только для чтения коллекции объектов букв.В конце строки на языке отсутствует символ, заканчивающийся на NULL; поэтому строка может содержать любое число внедренных символов NULL.Свойство длина строки представляет число объектов буква, содержащихся в этой строке, а не число символов Юникода.Для доступа к отдельным точкам в строке кода Юникода используется объект."; 
 
int len = s.Length; int j = 0;           
foreach (Char z in alf)           
 {                           
 for (int i = 1; i < len; ++i)             
 {                 
 if (z == s[i])                   
{k[j] = k[j] + 1; }             
 }             
 j = j + 1;      
}; j = 0;           
foreach (Char z in alf)           
 {               
 Console.WriteLine(j + " " + z + " " + k[j]); j = j + 1;           
 };           
Console.ReadKey();       
}   
 }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON Дано трехзначное число а. Определить: а) является ли произведение его цифр меньше числа а; б) кратна ли 5 сумма его цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vasinam
snabomp
infooem
daarisgoy
slastena69678
olg14855767
ilma20168
TatarkovTitova
yuip2008
isaev
madina27821667
Zibuxin3
uuks2012
enot1975
arionul-secondary2