Поделитесь своими знаниями, ответьте на вопрос:
10. Водяная мельница одним оборотом колеса дает х литров воды. Составить программу, которая определяет количество оборотов N, необходимых для получения V м3 . (м3 = 1000 л составить программу на Питоне или Паскале
const
n = 10;
var
a, i, sum: integer;
begin
sum := 0;
i := 1;
repeat
Write('Введите число = ');
Readln(a);
sum := sum + a;
i := i + 1;
until i > n;
Writeln('Среднее арифметическое = ', sum / n);
end.
//2
const
n = 10;
var
a, sum, i: integer;
begin
sum := 0;
i := 1;
while i <= n do
begin
Write('Введите число = ');
Readln(a);
sum := sum + a;
i := i + 1;
end;
Writeln('Среднее арифметическое = ', sum / n);
end.
//3
const
n = 10;
var
a, i, sum: integer;
begin
sum := 0;
for i := 1 To n Do
begin
Write('Введите число = ');
Readln(a);
Sum := Sum + a;
end;
Writeln('Среднее арифметическое = ', sum / n);
end.