qadjiyevaaynura
?>

Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность Введённые числа не превышают по модулю 90 000. Если чисел, оканчивающееся на 9, нет, то вывести «NO».

Информатика

Ответы

Владислав893

#include <iostream>

#include<bits/stdc++.h>

using namespace std;

int main()

{

  int min = INT_MAX,n;

  cin>>n;

  while (n != 0)

  {

      if (n%10==9)

      {

          if (n < min)

           min = n;

      }

      cin>>n;

  }

 

  if (min == INT_MAX)

       cout<<"No"<<endl;

  else

       cout<<"min = "<<min<<endl;

 

 

 

   return 0;

}

Объяснение:


Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное числ
Вячеславович-Дмитрий1694
MS DOS
Операционная система MS DOS (Microsoft Disk Operating System) – самая распространённая ОС на 16-разрядных персональных компьютерах, состоит из следующих модулей:базовой системы ввода/вывода (BIOS);блока начальной загрузки (Boot Record);модуля расширения базовой системы ввода/вывода (Io.SYS);модуля обработки прерываний (MsDos.SYS);командного процессора (Command.COM);утилит MS DOS.Каждый из указанных модулей выполняет определённую часть функций, возложенных на ОС. Места постоянного размещения этих модулей различны. Так, базовая система ввода/вывода находится в постоянном запоминающем устройстве (ПЗУ), а не на дисках как все остальные модули. Windows 1.0 Когда фирма Microsoft созвала пресс-конференцию на выставке Comdex, проходившей в ноябре 1985 года в Лас-Вегасе, многие посчитали это событие последним шансом, особенно после того как среда Windows не была выпущена, как было обещано, в июне того же года. Пресс-конференция плавно перетекла в презентацию нового продукта - Microsoft Windows 1.0. Windows95 Windows 95 представляет собой универсальную высокопроизводительную многозадачную и многопотоковую 32-разрядную ОС нового поколения с графическим интерфейсом и расширенными сетевыми возможностями. Windows 95 – интегрированная среда, обеспечивающая эффективный обмен информацией между отдельными программами и предоставляющая пользователю широкие возможности работы с мультимедиа, обработки текстовой, графической, звуковой и видео информации. Интегрированность подразумевает также совместное использование ресурсов компьютера всеми программами. Применяемый в Windows 95 защищённый режим не позволяет прикладной программе в случае сбоя нарушить работо системы, надёжно предохраняет приложения от случайного вмешательства одного процесса в другой, обеспечивает определённую устойчивость к вирусам. Пользовательский интерфейс Windows 95 прост и удобен. В отличие от оболочки Windows 3 эта операционная система не нуждается в установке на компьютере операционной системы DOS. Она предназначена для установки на настольный ПК и компьютерах блокнотного типа с процессором 486 или Pentium. Рекомендуемый размер оперативной памяти (ОЗУ) 8-32 Мбойт. После включения компьютера и выполнения программ BIOS операционная система Windows 95 автоматически загружается с жёсткого диска. После загрузки и инициализации системы на экране появляется рабочий стол, на котором размещены различные графические объекты. Пользовательский интерфейс спроектирован так, чтобы максимально облегчить усвоение этой операционной системы новичками и создать комфортные условия для пользователя.
Анатольевна824
Четное число делится на два, а кратное пяти делится на пять, поэтому число должно делиться без остатка на 2х5=10

// PascalABC.NET 3.0,сборка 1076
begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходная последовательность');
  a.Println;
  Writeln('Сумма элементов: ',a.Sum);
  Write('Кол-во четных, кратных пяти: ');
  Writeln(a.Where(x-> x mod 10 = 0).Count)
end.

Тестовое решение:
Длина последовательности: 20
Исходная последовательность
-4 21 -21 -23 14 -39 -12 1 -7 4 17 -45 30 -48 -19 -12 27 -46 -37 15
Сумма элементов: -184
Кол-во четных, кратных пяти: 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность Введённые числа не превышают по модулю 90 000. Если чисел, оканчивающееся на 9, нет, то вывести «NO».
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elozinskaya
yatania-popovich7
allaraygor
Soliyabronzoni
mkrtchyananaida6995
annasv8
zuzazuza61
Виктор Попова
Vos-sv
sergei-komissar8475
Galliardt Sergeevna1284
Кирилл-Анна1023
novdodCT
garikman-flesh486
gladkihvv
▲