kapi30
?>

Напишите (на языке Pascal) программу, которая переставляет строки матрицы так, чтобы значения в столбце K шли в порядке убывания. Строки, у которых значения в столбце K равны, должны быть выведены в том же порядке, в котором они стояли в исходной матрице. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. В последней строке вводится номер столбца K . Выходные данные Программа должна вывести получившуюся матрицу, в которой строки переставлены так, чтобы значения в столбце K шли в порядке убывания.

Информатика

Ответы

tatakypzova
Рассмотрим простейшую схему кредитования (и самую невыгодную для заёмщика), когда за каждый год отдается фиксированный процент p от первоначальной суммы кредита k без учета того, что часть кредита уже погашена за предыдущие годы.
В этом случае ежегодная сумма процентов по кредиту составит Sk=k×p%/100%.
За n лет будет отдано n×Sk. И еще нужно вернуть саму сумму кредита k.
Итого нужно вернуть k+n×Sk.
Доход за это время составит n×r и получаем неравенство
n×r ≥ n×Sk+k
n×(r-Sk) ≥ k → n ≥ k/(r-Sk) с округлением до целых в большую сторону.

// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (k,p):=ReadReal2('Сумма кредита и процент годовых:');
  var r:=ReadReal('Предполагаемый годовой доход:');
  var Sk:=k*p/100;
  if r<=Sk then Writeln('Рассчитаться за кредит невозможно')
  else Writeln('Количество лет на погашение кредита: ',Floor(k/(r-Sk)))
end.

Пример
Сумма кредита и процент годовых:10 0000 16
Предполагаемый годовой доход: 24000
Количество лет на погашение кредита: 12
neblondinka19
Трехразрядное число содержит вторую степень основания.
Это дает возможность сделать оценку верхнего значения основания системы счисления.
9² < √(73) < 8², поэтому система счисления не может иметь основание, большее 8.
Четырехразрядное число содержит третью степень основания. Это дает возможность сделать оценку нижнего значения основания системы счисления.
5³ < ∛(73) < 4³, поэтому система счисления не может иметь основание, меньшее 5.
Итак, у нас четыре претендента: натуральное n∈[5;8]

Для системы счисления по основанию n получаем уравнение
an²+bn+c=73

Для n=8 получим 64a+8b+c=73; a,b,c<8
Понятно, что a=1, тогда 8b+c=9. И тут понятно, что b=1 и тогда с=1.
Проверим. 111₈ = 1×8²+1×8+1=64+8+1=73

Нет смысла проверять n=7 и т.д., поскольку нам нужно наибольшее возможное основание.

ответ: 8

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите (на языке Pascal) программу, которая переставляет строки матрицы так, чтобы значения в столбце K шли в порядке убывания. Строки, у которых значения в столбце K равны, должны быть выведены в том же порядке, в котором они стояли в исходной матрице. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. В последней строке вводится номер столбца K . Выходные данные Программа должна вывести получившуюся матрицу, в которой строки переставлены так, чтобы значения в столбце K шли в порядке убывания.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gusrva3001
tcmir
vallzh8328
uvarovig
соловьев_Куркина
sandovo590
dkvsadovoe
verkop9
sn009
betepah
tarhan1221
Сергеевич1386
pbttehnology
anovikovsr
Сурат1199