amarantmetall
?>

Написать программу по заданному значению вывести соответствующую оценку с++

Информатика

Ответы

kozak8824

#include <iostream>

using namespace std;

int main()

{

   int n;

   cin>>n;

   switch (n){

   case 1:

       cout<<"Неуд.\n";

       break;

   case 2:

       cout<<"Неуд.\n";

       break;

   case 0:

       cout<<"Неуд.\n";

       break;

   case 3:

       cout<<"Удовл.\n";

       break;

   case 4:

       cout<<"Хорошо\n";

       break;

   case 5:

       cout<<"Отлично\n";

       break;

   }

   // Это долгий метод, но простой. Можно использовать контейнер map из STL

   return 0;

}

С отступами всё плохо. Прикреплю файл, копируй оттуда.

Nazart44446

Не переклеено ли фото на паспорте

При утере паспорта лучше как можно скорее бежать и писать заявление о пропаже. Ведь у нашедшего документ есть три варианта: оставить на память, отнести в милицию или продать дельцам, которые заменят в нем фото и продадут какому-нибудь мошеннику.

Не каждый отказаться от легких денег. Чем скорее вы явитесь с повинной, тем больше вероятность, что паспорт попадет в базу утерянных, наличие в которой не даст преступникам взять по нему кредит или продать сбежавшему зеку.

Чтобы выяснить, не терял ли кто паспорт вашего нового знакомого, надо пробить серию и номер документа по списку недействительных российских паспортов.

Настоящее ли разрешение на работу

Не фальшивое ли разрешение на въезд

Правильно ли указана прописка/регистрация

Не нарисованы ли права

Ну вроде как то так.

Объяснение:

Peshkov

являются подпрограммами. Подпрограмма – это именованная часть программы, представляющая собой некоторое собрание операторов, структурированных аналогично основной программе. Подпрограммы не необходимы, но их наличие заметно облегчает работу программиста и увеличивает «ценность» код, также как и во многих других языках программирования, переменные по отношению к программе делятся на локальные и глобальные. Те, которые объявляются в основной части, называются глобальными, а в процедуре или функции – локальными. Локальные переменные в отличие от глобальных могут использоваться лишь внутри подпрограммы, к которой они принадлежат.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу по заданному значению вывести соответствующую оценку с++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nefedova1432
stairov536
julya847
olgavbaranova
kondrashovalf6404
gordeevadesign2986
ars-trushakova
alexk13
Reutskii884
Михайловна-Гусева350
beaevgen711
Nikolaevich-Svetlana388
struev2003260
Михаил736
Yurevich1243
▲