Иванов1813
?>

Язык - Python Развернуть элементы с нечетными индексами Вам дан список целых чисел. Разверните элементы с нечетными индексами. Входные данные Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке. Выходные данные Выведите получившийся список. Примеры Ввод 1 2 3 4 5 Вывод 1 4 3 2 5

Информатика

Ответы

asker45967

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

Ермакова Ирина674
План введение 1. понятие информационной культуры 2. компоненты информационной культуры 3. проблемы формирования информационной культуры заключениевведение место образования в жизни современного общества во многом определяется возрастающей ролью знаний, информации, что отразилось в концепциях информационного общества, становлении информационной цивилизации, информатизации образования. в контексте происходящих инновационных изменений в обществе, вызванных повсеместным внедрением компьютерных технологий, одной из актуальнейших развития современного образования в россии и за рубежом является информатизация и реализация тенденций развития образования в условиях информационного общества. быстрому развитию компьютерных технологий люди имеют доступ к самой разнообразной информации в любой точке планеты, обмениваются информацией, общаются в режиме реального времени. для свободной ориентации в информационных потоках современный специалист любого профиля должен уметь получать, обрабатывать и использовать информацию с компьютеров, телекоммуникаций и других средств связи. но для этого необходимо знать правила навигации по огромному количеству доступной информации и обладать определенной информационной культурой. 1. понятие информационной культуры информационная культура - это новый тип общения, возможность свободного выхода личности в информационное бытие; свобода выхода и доступ к информационному бытию на всех уровнях от до локального, поскольку внутринациональный, внутригосударственный тип информационного бытия так же несостоятелен, как и национальная наука; новый тип мышления, формирующийся в результате освобождения человека от рутинной информационно-интеллектуальной работы, среди черт, определяющих его, уже сегодня ярко проявляется ориентация последнего на саморазвитие и самообучение. в понятии "информационная культура" ведущим является слово "культура", именно оно заключает в себе наибольшую смысловую нагрузку. исследования виднейших отечественных культурологов позволяют определить культуру как сложное понятие, означающее результат, процесс, способ, отношение, норму, систему деятельности, единственным субъектом и преимущественным объектом которой является человек. информационная культура – это [михайловский в. н., с. 56]: - новый тип общения, возможность свободного выхода личности в информационное бытие;- свобода выхода и доступ к информационному бытию на всех уровнях от до локального, поскольку внутринациональный, внутригосударственный тип информационного бытия так же несостоятелен, как и национальная наука
bmargarita

Язык Паскаль был создан Никлаусом Виртом в 1968—1969 годах после его участия в работе комитета разработки стандарта языка Алгол-68. Язык назван в честь французского математика, физика, литератора и философа Блеза Паскаля, который создал первую в мире механическую машину, складывающую два числа.

Блез Паскаль появился на свет 19 июня 1623 года в городке Клермон-Ферран на юге Франции.

в 1640 году свет увидел «Опыт теории конических сечений», ставший основополагающим трактатом для дальнейших трудов в области геометрии.

в 1642 году Блез занимался разработкой чудо-аппарата. Его арифмометр, сделанный по принципу античного таксометра, выглядел как ящик с многочисленными шестеренками и позволял производить расчеты с шестизначными числами, а подсчет производился в полуавтоматическом режиме.

В конце 1646 года Блез Паскаль, узнав о трубке, изобретенной Торричелли, стал увлекаться физикой. Ученый начал ставить эксперименты, доказывая, что гипотеза Аристотеля о «боязни пустоты» имеет пределы.

Блез видоизменил этот эксперимент и сделал заключение, что верхняя часть трубки не наполнена парами химического вещества, тонкой материей или иной субстанцией. Результаты своей работы Паскаль опубликовал в трактате «Новые опыты, касающиеся пустоты», а далее стремился прийти к выводу, что столбик с ядовитым металлом удерживается давлением воздуха.

Кроме того, Блез Паскаль выпустил в свет рукопись «Трактат о равновесии жидкостей» (1653), сформировал идею гидравлического пресса и установил основной закон гидростатики, опровергнув учение древнегреческого философа.

в 1652 году удостоился признания и славы, презентовав свою суммирующую машинку шведской королеве Кристине.

Умер в 1662 году, Париж, Франция.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Язык - Python Развернуть элементы с нечетными индексами Вам дан список целых чисел. Разверните элементы с нечетными индексами. Входные данные Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке. Выходные данные Выведите получившийся список. Примеры Ввод 1 2 3 4 5 Вывод 1 4 3 2 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vladimirovna-Ignatenko1890
Kuznetsova1639
ksv89
v79150101401
Анна1417
ludmila-malev280
volkovaoksana19806037
svetegal
info7
os2854
Манько_Панферов
Бегун-Марина
gulyaizmailova
Dmitrievich1871
DJXEz80
▲