Dmitrievich1871
?>

программа рекурсии находит N-е число Фибоначчи с течением времени T. За сколько времени эта программа найдет N + 1 число? N + 2? 2N?

Информатика

Ответы

Aleksei
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x

Программа:

var x, y, z: real;
begin
  writeln('Введите стороны треугольника x, y, z: ');
  read(x, y, z);
  if (x + y > z) and (x + z > y) and (y + z > x) 
  then writeln('Треугольник существует')
  else writeln('Треугольник не существует');
end.

2. Думаю, здесь излишни объяснения.

Программа:

var x, y, z: real;
begin
  writeln('Введите три числа: ');
  read(x, y, z);
  writeln('В интервале (1; 3) лежат числа: ');
  if (x > 1) and (x < 3) then writeln(x);
  if (y > 1) and (y < 3) then writeln(y);
  if (z > 1) and (z < 3) then writeln(z);
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Chikichev456

Координаты даны в двоичной системе счисления, поэтому переводим их в десятичную.

Потом сортируем по порядку по номерам точек.

И отмечаем точки на графике, соединяя соседние отрезком.

Я все эти преобразования сделал в таблице Эксель.

Саму таблицу и картинку, полученную после нанесения всех точек смотри внизу.

А вот координаты точек, отсортированные и в десятичной системе:

№     x     y

1     11     7

2     12     7

3     13     6

4     13     5

5     14     6

6     15     6

7     16     5

8     15     5

9     12     3

10     10     1

11     7     1

12     5     2

13     4     1

14     2     2

15     3     2

16     4     3

17     3     6

18     1     7

19     3     8

20     4     8

21     5     7

22     6     5

23     7     6

24     9     6

25     8     5

26     7     5

27     8     4

28     10     4

29     12     5

30     12     6

31     11     7


Восстановите рисунок по заданным координатам. Расставьте точки и соедините их в правильном порядке.
Восстановите рисунок по заданным координатам. Расставьте точки и соедините их в правильном порядке.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

программа рекурсии находит N-е число Фибоначчи с течением времени T. За сколько времени эта программа найдет N + 1 число? N + 2? 2N?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

barekyan096140
lbeglarova6
avdeevo
Vladimirovna-Ignatenko1890
polusik120796
Vladstreletskiy
Александр Сергей
Kalashnikova
nadezhda81
Nikolaevich_Vladimirovich1509
Bella
Лифанов_Ольга
ivanov568
Бегун-Марина
Джамал1009
▲