vasiliyglukhov
?>

(Python)Напишите программу, которая будет пять раз выводить позыв "Ауу!".​

Информатика

Ответы

Zhanna417

[print('Ayy!') for i in range(5)]

Объяснение:

НиколаевнаОльга

Python

Объяснение:

Выше уже написали ответ, поэтому не буду повторяться и напишу подлиннее код:

n = "Ауу!"

for i in range(6):

   print(n)

вывод:

Ауу!

Ауу!

Ауу!

Ауу!

Ауу!

Ауу!

Так же можно вывести в одну строку:

n = "Ауу!"

print(*n * 5)

вывод:

А у у ! А у у ! А у у ! А у у ! А у у !

и тоже в одну строчку:

print("Ауу!" * 5)

вывод:

Ауу!Ауу!Ауу!Ауу!Ауу!

colus77

Для определения информационного объема сообщения воспользуемся формулой: I = K * i,  где K - количество символов, i - вес одного символа.

1)  1024 стра­ни­цы, на одной стра­ни­це по­ме­ща­ет­ся 64 стро­ки, а в стро­ке по­ме­ща­ет­ся 64 сим­во­ла. Каж­дый сим­вол в ко­ди­ров­ке КОИ-8 за­ни­ма­ет 8 бит па­мя­ти.

i = 8 бит

K = 1024 * 64 * 64 = 4194304 символов,

I = 4194304 * 8 = 33554432 бит = 4194304 байт = 4096  Кбайт = 4 Мбайт

2) 512 стра­ниц, на одной стра­ни­це в сред­нем по­ме­ща­ет­ся 64 стро­ки, а в стро­ке 64 сим­во­ла. (Каж­дый сим­вол в ко­ди­ров­ке Unicode за­ни­ма­ет 16 бит па­мя­ти.)

i = 16 бит

K = 512 * 64 * 64 = 2097152 символов,

I = 2097152 * 16 = 33554432 бит = 4194304 байт = 4096 Кбайт = 4 Мбайт

*8 бит = 1 байт

1024 байт = 1 Кбайт

1024 Кбайт = 1 Мбайт

Овчинников_Грузман
1. Программа для создания файла

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
  tBook=record
    author:string[30];
    naim:string[50];
    pages:integer;
    godizd:integer
    end;
begin
  var f:file of tBook;
  Rewrite(f,'books.dat');
  Writeln('Ввод данных по книгам');
  var s1,s2:string;
  var i1,i2:integer;
  var book:tBook;
  repeat
    s1:=ReadlnString('Автор или * для окончания ввода:');
    if s1<>'*' then begin
      s2:=ReadlnString('Название книги:');
      i1:=ReadlnInteger('Количество страниц:');
      i2:=ReadlnInteger('Год издания:');
      (book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2);
      Write(f,book)
      end
  until s1='*';
  Writeln('*** Ввод завершен ***');
  f.Close
end.

Тестовое решение
Ввод данных по книгам
Автор или * для окончания ввода: Жюль Верн
Название книги: 80 тысяч километров под водой
Количество страниц: 573
Год издания: 1951
Автор или * для окончания ввода: Сергей Лукьяненко
Название книги: Дозор
Количество страниц: 934
Год издания: 2004
Автор или * для окончания ввода: Жюль Верн
Название книги: Властелин мира
Количество страниц: 104
Год издания: 2011
Автор или * для окончания ввода: *
*** Ввод завершен ***

2. Программа для выборки

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
  tBook=record
    author:string[30];
    naim:string[50];
    pages:integer;
    godizd:integer
    end;
begin
  var f:file of tBook;
  Reset(f,'books.dat');
  var s:=ReadlnString('Автор книги:');
  var y:=Readinteger('Год издания, не ранее:');
  var k:=0;
  var book:tBook;
  while not f.Eof do begin
    Read(f,book);
    if (book.author=s) and (book.godizd>=y) then begin
      Writeln(book);
      Inc(k)
      end;
  end;
  if k=0 then Writeln('Таких книг не найдено');
  f.Close
end.

Тестовое решение
Автор книги: Жюль Верн
Год издания, не ранее: 2005
(Жюль Верн,Властелин мира,104,2011)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

(Python)Напишите программу, которая будет пять раз выводить позыв "Ауу!".​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Marianna45
musaevartur
Latsukirina
Feyruz90
galinab1111326
dokmak140652
tvshi
R7981827791127
Solovetzmila
bruise6
elmiro4ka868617
anusha33325
levickaalubov5
andrewa
metegina4