teashop
?>

с машиной Поста! 1) Дано несколько массивов. Определить их количество. Каретка находится над крайней левой меткой первого массива. 2) Составьте программу для машины Поста, которая удаляет каждую пятую метку в выражении, если каретка стоит справа от выражения. Слова в выражении разделены пустой ячейкой. 3) Дан массив меток. Каретка располагается слева над первой меткой массива. Стереть все метки, кроме крайних

Информатика

Ответы

yaudo47
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13
ella440
№1

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > -2.4 ) AND ( x < 5.7 ) then F := sqr(x)
else F := 4;
writeln('F = ', F);
end.

№2

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > 0.2 ) AND ( x < 0.9 ) then F := sin(x)
else F := 1;
writeln('F = ', F);
end.

№3

var a,b,c: real;
begin
write('Введите а: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
if ( a < b ) AND ( b < c ) then writeln('a < b < c')
else
if ( b > a ) AND ( a > c ) then writeln('b > a > c')
else
writeln('Неравенства не выполняются');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с машиной Поста! 1) Дано несколько массивов. Определить их количество. Каретка находится над крайней левой меткой первого массива. 2) Составьте программу для машины Поста, которая удаляет каждую пятую метку в выражении, если каретка стоит справа от выражения. Слова в выражении разделены пустой ячейкой. 3) Дан массив меток. Каретка располагается слева над первой меткой массива. Стереть все метки, кроме крайних
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

TatarkovTitova
Gaziev1636
mustaevdmitry397
borisovaks496
testovvanya
Назаренко1075
Moroshkina-Aristova2011
Shpunt-86
ПаршинАндрей1928
saniopt
ilez03857
Klyucharyova
igevskoemuseumkec
петрАфанасьев
ooo-krasa