Maksimova1320
?>

Я хотел выполнить задание на курсерах ""Тренировочное задание по программированию: Котлеты*"" вот условие: На сковородку одновременно можно положить k котлет. Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно. За какое наименьшее время удастся поджарить с обеих сторон n котлет? Формат ввода Программа получает на вход три числа: k, m, n. Формат вывода Программа должна вывести одно число: наименьшее количество минут. Вот моя прога: kotlet, minut1, newKotlet = int(input()), int(input()), int(input()) minut = minut1 * 2 formula1 = newKotlet % kotlet if formula1 == 0: print((newKotlet // kotlet) * minut) else: print(((newKotlet // kotlet) * minut) + minut) Но она выдаёт ошибку: Test 1 input: 1 5 1 Runtime error

Информатика

Ответы

peresvetoff100015
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.
sergeystepanov231

1. Чтобы решить задачу, надо определить, какое количество варенья съест Машенька за 20 дней. Вначале вычислим это количество в ложках, если известно, что за день она съедает по 5 ложек варенья:

5 * 20 = 100 ложек.

2. Теперь переведем 100 ложек варенья в граммы, если известно, что каждая ложка помещает 5 г варенья:

100 * 5 = 500 грамм.

3. Если исходное количество варенья составляет 650 грамм, тогда вычтем из этой массы ту часть, что съест Машенька за 20 дней и получим массу оставшегося варенья через 20 дней:

650 - 500 = 150 грамм.

ответ: получили, что через 20 дней в банке останется всего 150 грамм варенья.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Я хотел выполнить задание на курсерах ""Тренировочное задание по программированию: Котлеты*"" вот условие: На сковородку одновременно можно положить k котлет. Каждую котлету нужно с каждой стороны обжаривать m минут непрерывно. За какое наименьшее время удастся поджарить с обеих сторон n котлет? Формат ввода Программа получает на вход три числа: k, m, n. Формат вывода Программа должна вывести одно число: наименьшее количество минут. Вот моя прога: kotlet, minut1, newKotlet = int(input()), int(input()), int(input()) minut = minut1 * 2 formula1 = newKotlet % kotlet if formula1 == 0: print((newKotlet // kotlet) * minut) else: print(((newKotlet // kotlet) * minut) + minut) Но она выдаёт ошибку: Test 1 input: 1 5 1 Runtime error
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lyudmila-Popova
Shalito
ellyb106786
Марина_Мария
ПетросовичЗаславский
slipu817838
merzlikinairena
cardiodoc08
gorod7
misstimarina2016
M10M11M12
alesia1986
Paikina Natalya30
Borisovna24
Rustamov741