Ирина-Макаркина253
?>

нужно написать программу Даны x, y, z. Вычислить a, b, если: a = ln ( y - Ö |x| ) (x - y ) ; b=x - x2/3 + x5/5 . z + x2/4

Информатика

Ответы

irinalav2705745

1) Пароль в этом коде - "zn4n1j4". Заменить при необходимости.

var

 i: integer;

 s: string;


begin

 i := 1;

 while i <= 5 do

 begin

   readln(s);

   if s = 'zn4n1j4' then

   begin

     writeln('Вход в систему разрешен');

     exit;

   end;

   writeln('Неверный пароль.');

 end;

 writeln('Пароль не был угадан 5 раз.');

end.


2) Используем операцию x mod 10 для получения последней цифры числа и x div 10 для "отбрасывания" последней цифры числа.

var

 x, ans: integer;


begin

 read(x);

 ans := 0;

 while x <> 0 do

 begin

   ans := ans + (x mod 10);

   x := x div 10;

 end;

 writeln(ans);

end.

Сергеевич

1) Пароль в этом коде - "zn4n1j4". Заменить при необходимости.

var

 i: integer;

 s: string;


begin

 i := 1;

 while i <= 5 do

 begin

   readln(s);

   if s = 'zn4n1j4' then

   begin

     writeln('Вход в систему разрешен');

     exit;

   end;

   writeln('Неверный пароль.');

 end;

 writeln('Пароль не был угадан 5 раз.');

end.


2) Используем операцию x mod 10 для получения последней цифры числа и x div 10 для "отбрасывания" последней цифры числа.

var

 x, ans: integer;


begin

 read(x);

 ans := 0;

 while x <> 0 do

 begin

   ans := ans + (x mod 10);

   x := x div 10;

 end;

 writeln(ans);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно написать программу Даны x, y, z. Вычислить a, b, если: a = ln ( y - Ö |x| ) (x - y ) ; b=x - x2/3 + x5/5 . z + x2/4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

evg-martenyuk
fedotochkin8
slonikkristi69
barg562
skyey
marketing
georgegradoff122
lihacheva
akakne86
Tatianarogozina1306
Olifirenko119
Sergeevich-Drugov1513
27mod 3 = 41div 9 = 10 div4 +50 mod3 =
kush-2640
Bmashutav16
Баранов955