buslavgroupe
?>

1)Оператор … предназначен для организации выбора одного из многих вариантов хода выполнения программы, выполняя проверку совпадения заданного выражения с одной из заданных констант и осуществляя ветвление на основе этой проверки. вместо точек один из вариантов A)WHILE B)BREAK C)GOTO D)SWITCH 2)Чему равно значение величин а и в после выполнения приведенных операций присваивания, если до начала этих действий а=15, в=1. а = а – в; в = 7; а = а + в: A)А=15, В=7 B)А=21, В=7 C)А=9, В=24 3)Что из ниже перечисленного не является языком программирования: A)Cobol B)HTML C)С++ D)Assembler 4)Значение величин, которые занимают место в памяти, имеют имя и определенный тип, и их значение никогда не меняется, называется A)константа B)постоянная C)целая величина D)переменная 5)После перевода в восьмеричную систему счисления десятичное число 110, 175 будет равно: A)126, 4(3155) B)159, 2(3164) C)156, 1(3146) 6)Для чего нужен деструктор в с++? A)для обнуления переменной B)для возвращения системе области памяти, выделенной при выполнении конструктора, а также для закрытия файлов перед окончанием работы с объектом, открывшим этот файл C)для уничтожения функции D)для освобождения области памяти, выделенной для всей программы 7)Какой язык программирования был придуман раньше других? a)Pascal B)Assembler C)C D)Fortran 8)Последовательность символов, заключенная в двойные кавычки называется A)управляющая последовательность B)символ C)строковая константа D)идентификатор 9)Назовите значение величин а и в после выполнения приведенных операций присваивания, если до начала этих действий а = «крокодил», в = «обезьяна». а:= в; в:= а; A)А = «крокодил», В= «обезьяна» B)А = «обезьяна», В= «обезьяна» C)А = «крокодил», В= «крокодил» D)А = «обезьяна», В= «крокодил» 10)Какая ошибка допущена в данной программе: #include main( ) { printf ("\\n hi, world!\\n") } A)отсутствует точка с запятой в функции B)нет точки в конце тела функции C)не определена переменная 11)Можно ли в языке программирования си создать массив указателей? A)да B)нет 12)Содержать буквы любого алфавита, цифры, специальные знаки может ... вместо точек один из вариантов A)оператор B)идентификатор C)функция комментарий 13)Языки программирования можно разделить на языки: A)высокого и низкого уровня B)среднего уровня C)переходного уровня 14) Мультипликативные операции относятся к блоку A)унарных операций B)тернарных операций C)бинарных операций 15)___ – это программа, переводящая текст инструкций для компьютера с какого-либо языка программирования на машинный язык. A)язык программирования B)система программирования C)кодировщик D)компилятор С ТЕСТОМ ОГРОМНОЕ КТО

Информатика

Ответы

Юлия-Ольга1313
D)B)B)A)С)B)B)C)B)A)A)D)A)C)D)
predatorfishing608
Трудно сказать не видя структуры твоего калькулятора. Если у тебя два поля для ввода чисел (edit1 и edit2), а результат записываешь в Memo1 (кстати, а зачем именно тип Memo?), то можно сделать следующим образом (пример для кнопок "+" и "-")

procedure TForm1.PlusClick(Sender: TObject);
var x,y:real;
r:string;
begin
   val(edit1.Text,x);
   val(edit2.Text,y);
   str(x+y,r);
  Memo1.Lines[0]:=edit1.Text+'+'+edit2.Text+'='+r;
end;

procedure TForm1.MinusClick(Sender: TObject);
var x,y:real;
r:string;
begin
   val(edit1.Text,x);
   val(edit2.Text,y);
   str(x-y,r);
  Memo1.Lines[0]:=edit1.Text+'-'+edit2.Text+'='+r;
end; 
АльбертовичБерезин58
Вторая задача, Паскаль АВС

Program  Robiertmusin;
uses crt;
const n = 15;
type
  MyArray = array [1..n,1..n] of integer;

procedure ArrayOutput(A: MyArray);
var i,j: integer;
begin
  for i := 1 to n do
    begin
       for j:= 1 to n do
         write(A[i,j]:4, ' ');
       writeln;
    end;
  writeln;
end;

procedure RowSort(var A: MyArray; Nom: integer);
var i, j, temp: integer;
begin
  for i := 1 to n-1 do
    for j := i+1 to n do
      if A[nom,i]>A[nom,j] then begin
        temp:=A[nom,i];
        A[nom,i]:=A[nom,j];
        A[nom,j]:=temp;
      end;
  writeln(nom,'-я строка упорядочена');
end;

var
  mass:MyArray;
  i,j:integer;
begin
  writeln('В матрице целых чисел А (n*n) программа упорядочивает те строки,');   writeln('в которых диагональные элементы не содержат семерок');
{Создаём начальный массив и выводим его}
  randomize;
  for i := 1 to n do
     for j:= 1 to n do
         mass[i,j]:=random(20);
  ArrayOutput(mass);
{Просматриваем строки}
  for i := 1 to n do
    begin
       if (mass[i,i]<>7) and (mass[n-i+1,n-i+1]<>7)  then RowSort(mass, i);
    end;        
{Выводим итоговый массив}
  writeln('Упорядоченный массив: ');
  ArrayOutput(mass);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)Оператор … предназначен для организации выбора одного из многих вариантов хода выполнения программы, выполняя проверку совпадения заданного выражения с одной из заданных констант и осуществляя ветвление на основе этой проверки. вместо точек один из вариантов A)WHILE B)BREAK C)GOTO D)SWITCH 2)Чему равно значение величин а и в после выполнения приведенных операций присваивания, если до начала этих действий а=15, в=1. а = а – в; в = 7; а = а + в: A)А=15, В=7 B)А=21, В=7 C)А=9, В=24 3)Что из ниже перечисленного не является языком программирования: A)Cobol B)HTML C)С++ D)Assembler 4)Значение величин, которые занимают место в памяти, имеют имя и определенный тип, и их значение никогда не меняется, называется A)константа B)постоянная C)целая величина D)переменная 5)После перевода в восьмеричную систему счисления десятичное число 110, 175 будет равно: A)126, 4(3155) B)159, 2(3164) C)156, 1(3146) 6)Для чего нужен деструктор в с++? A)для обнуления переменной B)для возвращения системе области памяти, выделенной при выполнении конструктора, а также для закрытия файлов перед окончанием работы с объектом, открывшим этот файл C)для уничтожения функции D)для освобождения области памяти, выделенной для всей программы 7)Какой язык программирования был придуман раньше других? a)Pascal B)Assembler C)C D)Fortran 8)Последовательность символов, заключенная в двойные кавычки называется A)управляющая последовательность B)символ C)строковая константа D)идентификатор 9)Назовите значение величин а и в после выполнения приведенных операций присваивания, если до начала этих действий а = «крокодил», в = «обезьяна». а:= в; в:= а; A)А = «крокодил», В= «обезьяна» B)А = «обезьяна», В= «обезьяна» C)А = «крокодил», В= «крокодил» D)А = «обезьяна», В= «крокодил» 10)Какая ошибка допущена в данной программе: #include main( ) { printf ("\\n hi, world!\\n") } A)отсутствует точка с запятой в функции B)нет точки в конце тела функции C)не определена переменная 11)Можно ли в языке программирования си создать массив указателей? A)да B)нет 12)Содержать буквы любого алфавита, цифры, специальные знаки может ... вместо точек один из вариантов A)оператор B)идентификатор C)функция комментарий 13)Языки программирования можно разделить на языки: A)высокого и низкого уровня B)среднего уровня C)переходного уровня 14) Мультипликативные операции относятся к блоку A)унарных операций B)тернарных операций C)бинарных операций 15)___ – это программа, переводящая текст инструкций для компьютера с какого-либо языка программирования на машинный язык. A)язык программирования B)система программирования C)кодировщик D)компилятор С ТЕСТОМ ОГРОМНОЕ КТО
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ldstroy
Khiryanov
Rakitin
far-yuliya128
хаджимурод1172
pechyclava
starabanov
dimiff5
Petrovich
lika080489
Пономаренко
azarovaelena19812
Kuzina Sergeevna
AleksandraRuslan504
maglevanyycpt