qwert28027170
?>

На вход программе подается два натуральных числа a и b (a < b Напишите программу, которая находит все простые числа от a до b включительно. Python

Информатика

Ответы

anusha33325

var a, b, i, j, l: integer;

begin

read(a, b);

for i:=a to b do

begin

j:=2;

l:=round(sqrt(i));

while (i mod j <> 0) and (j <= l) do

inc(j);

if j > l then write(i, ' ');

end;

end.

tatasi
Const
   N = 4;
Var
   A:array[1..N,1..N] of integer;
   i,j,k:integer;
Begin
Randomize;
WriteLn('1)');
k:=0;
For i:= 1 to N do
    Begin
    For j:= 1 to N do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ');
        if A[i,j] < 0 then k:=k+1;
        End;
    WriteLn
    End;
WriteLn('k = ',k);
WriteLn('2)');
For i:= 1 to N do
    Begin
    For j:= 1 to N do
        Begin
        if j > i then A[i,j]:=100;
        Write(A[i,j]:3,' ')
        End;
    WriteLn
    End;
WriteLn('3)');
For i:= 1 to N div 2 do
    Begin
    For j:= 1 to N do
        Begin
        k:=A[i+N div 2,j];
        A[i+N div 2,j]:=A[i,j];
        A[i,j]:=k;
        End
    End;
For i:= 1 to N do
    Begin
    For j:= 1 to N do
        Write(A[i,j]:3,' ');
    WriteLn
    End;
End.

1)
 10   2  -9   4
-10   5  -5 -10
  4   9   4  10
  3  -9  10  -6
k = 6
2)
 10 100 100 100
-10   5 100 100
  4   9   4 100
  3  -9  10  -6
3)
  4   9   4 100
  3  -9  10  -6
 10 100 100 100
-10   5 100 100
rstas

{ Задача по информатике решить в паскале Имеется продуктовая база в которой можно
закупить партию товара по условиям минимальная стоимость , близость поставки ,
прочность товара Если товар удолетворяет - закупаем
Если ее удолетворяет - не закупаем
Мы вводим данные близость поставки, прочность товара, и минимальная стоимость
если все три условия выполняются ввыводим закупаем а
если не выполняются выводи не закупается}
type
    WareData = record
        MinPrice: integer;
        Distance: integer;
        Strength: real;
    end;

var
    Base, Client: WareData;

begin
    Base.MinPrice := 4;
    Base.Distance := 57;
    Base.Strength := 0.25;
    
    read(Client.MinPrice, Client.Distance, Client.Strength);
    if (Client.MinPrice >= Base.MinPrice)
        and (Client.Distance >= Base.Distance)
        and (Client.Strength <= Base.Strength) then
        writeln('Берем')
    else
        writeln('Не устраивает');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программе подается два натуральных числа a и b (a < b Напишите программу, которая находит все простые числа от a до b включительно. Python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Plotnikovangav
Владимирович111
dksvetlydir
MikhailSvetlana
olimov9
saytru5850
Aleksandr-Andrei
leonidbaryshev19623
Владимирович111
ibombenkova
zabrodin
Tkachenko1050
masamosijcuk140244
Николаевна_Анна670
tarkhanovilya