irina-mic
?>

Python Напишите программу, которая добавляет n элементов в множество и выводит в результате сколько элементов находится в множестве.Входные данные: На первой строке - целое число n.На следующих строках n элементов, которые нужно добавить в множество.Выходные данные:Целое число - количество элементов в множестве.​

Информатика

Ответы

goldenshtein33333

n = int(input())

s = set()

for i in range(n):

   e = int(input())

   s.add(e)

print(len(s))

Vladimir
Программа может выглядеть так:

uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
    i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to  n do
   begin
   A[i]:=10+random(90);
   Write (A[i]:5);
   end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
  if A[i]<Min then
     begin
       Min:=A[i];
       MinInd:=i;
     end
     else
       if A[i]>Max then
       begin
       Max:=A[i];
       MaxInd:=i;
     end;
end;
 temp:=A[MaxInd];
 A[MaxInd]:=A[MinInd];
 A[MinInd]:=temp;
 WriteLn;WriteLn;
 for i:=1 to  n do
   Write (A[i]:5);
 WriteLn;
 ReadLn;
end.
andreanikin
Программа может выглядеть так:

uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
    i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to  n do
   begin
   A[i]:=10+random(90);
   Write (A[i]:5);
   end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
  if A[i]<Min then
     begin
       Min:=A[i];
       MinInd:=i;
     end
     else
       if A[i]>Max then
       begin
       Max:=A[i];
       MaxInd:=i;
     end;
end;
 temp:=A[MaxInd];
 A[MaxInd]:=A[MinInd];
 A[MinInd]:=temp;
 WriteLn;WriteLn;
 for i:=1 to  n do
   Write (A[i]:5);
 WriteLn;
 ReadLn;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python Напишите программу, которая добавляет n элементов в множество и выводит в результате сколько элементов находится в множестве.Входные данные: На первой строке - целое число n.На следующих строках n элементов, которые нужно добавить в множество.Выходные данные:Целое число - количество элементов в множестве.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksandr72
KrisTinka
ВалентиновичСуриковна1104
allo01
chermen40
info40
Татьяна
artbogema2016
lyukiss
kashihina
petrakovao
Корнеплодович1930
suhanowaswetlana
mila-vsv
Mariya987