Sergei
?>

Условие задачи Нужно сделать на Python!!Ограничение времени, с 1Ограничение памяти, МБ 64Общее число попыток отправки 15На вход подается 2 строки. Нужно определить, можно ли превратить первую строку во вторую, заменяя одни буквы на другие, с учетом следующих правил:- участвуют только буквы русского алфавита а-я;- все буквы в нижнем регистре;- за один шаг можно преобразовать все вхождения одной буквы в другую.Входные данныеВходная информация поступает из стандартного ввода в виде одной строки. В этой строке содержатся две подстроки, разделенные пробелом. Ваше решение должно учитывать вариант, когда на вход поданы строки разной длины. Некорректные данные на вход не поступают, дополнительные проверки не требуются.Выходные данныеВ качестве ответа в стандартный вывод программа должна выводить 1 (если превратить можно) или 0 (если превратить нельзяПример 1Входные данные: привет приколВыходные данные: 1Преобразования (выводить не нужно):в ⇒ к (прикет)е ⇒ о (прикот)т ⇒ л (прикол)Пример 2Входные данные: ааббдд ддббааВыходные данные: 1Преобразования (выводить не нужно):д ⇒ я (ааббяя)а ⇒ д (ддббяя)я ⇒ а (ддббаа)Пример 3Входные данные: абаб ааахВыходные данные: 0Преобразовать нельзя, так как 'б' не сможет оказаться одновременно 'а' и 'х'.Примечания по оформлению решенияПри отправке решений на Java необходимо назвать исполняемый класс Main. В решении не нужно указывать пакет.Для работы со стандартным потоком ввода в JS используйте require('readline'), а для работы со стандартным потоком вывода - console.log(String(data)).Пример ввода-вывода на JS:const readline = require('readline');const rl = readline.createInterface(process.stdin, process.stdout);rl.on('line', (line) => { // Введенная строка в переменной line, тут можно написать решение console.log(String(result)); rl.close(); return;}).on('close', () => process.exit(0));Нужно сделать на Python!

Информатика

Ответы

misstimarina2016

Прикрепил скрин с программой и результатами работы на тестовых примерах.

Время и память очень зависят от компьютера, на котором проводится тестирование и размерам тестируемых строк.

============

Не забывайте нажать " ", поставить оценку и, если ответ удовлетворил, то выберите его как "Лучший"

Бодрого настроения и добра!

Успехов в учебе


Условие задачи Нужно сделать на Python!!Ограничение времени, с 1Ограничение памяти, МБ 64Общее число
fta1309
Var
  m, n: integer;
  s1, s2, s3: string;
  ms: array[1..9] of string;
  md: array[1..9] of string;
  m1: array[11..19] of string;
  me: array[1..9] of string;
  flag: boolean;

begin
 
  flag := false; { Пока ничего не выведено }
  s1 := 'рубль';
  s2 := 'рубля';
  s3 := 'рублей';
  ms[1] := 'сто'; ms[2] := 'двести'; ms[3] := 'триста'; ms[4] := 'Четыреста';
  ms[5] := 'пятьсот'; ms[5] := 'пятьсот'; ms[6] := 'шестьсот'; ms[7] := 'семьсот';
  ms[8] := 'восемьсот'; ms[9] := 'девятьсот';
  md[1] := 'десять'; md[2] := 'двадцать'; md[3] := 'тридцать'; md[4] := 'сорок';
  md[5] := 'пятьдесят'; md[6] := 'шестьдесят'; md[7] := 'семьдесят';
  md[8] := 'восемьдесят'; md[9] := 'девяносто';
  m1[11] := 'одиннадцать'; m1[12] := 'двенадцать'; m1[13] := 'тринадцать';
  m1[14] := 'четырнадцать'; m1[15] := 'пятнадцать'; m1[16] := 'шестнадцать';
  m1[17] := 'семнадцать'; m1[18] := 'восемнадцать'; m1[19] := 'девятнадцать';
  me[1] := 'один'; me[2] := 'два'; me[3] := 'три'; me[4] := 'четыре'; me[5] := 'пять';
  me[6] := 'шесть'; me[7] := 'семь'; me[8] := 'восемь'; me[9] := 'девять';
 
  Write('Введите целое число от 1 до 1000: ');
  Readln(m);
  if (m < 1) or (m > 1000) then Writeln('Шутки шутим?')
  else
  if m = 1000 then Writeln('Одна тысяча ' + s3)
    else
  begin
      { сотни }
    n := m div 100;
    if n > 0 then
    begin
      Write(ms[n]);
      flag := true
    end;
      { десятки }
    m := m mod 100;
    if m = 0 then Writeln(' ', s3)
    else
    begin
      if (m > 10) and (m < 20) then
      begin
        if flag then Write(' ');
        Writeln(m1[m], ' ', s3)
      end
      else
      if m > 0 then
      begin
        n := m mod 10;
        m := m div 10;
        if m > 0 then
        begin
          if flag then Write(' ') else flag := true;
          Write(md[m])
        end;
        if n <> 0 then
        begin
          { единицы }
          if flag then Write(' ');
          Write(me[n], ' ');
          case n of
            1: Writeln(s1);
            2..4: Writeln(s2);
          else Writeln( s3)
          end
        end
        else Writeln(' ', s3)
      end
    end
  end
end.

Тестовое решение:
Введите целое число от 1 до 1000: 314
триста четырнадцать рублей
punctvydachi
) В числе не меньше двух цифр, которые меньше шести.
Следовательно, в числе две цифры в диапазоне от 0 до 5, а третья может быть и больше.
2) В числе не меньше двух четных цифр.
Следовательно, в числе одно цифра может быть и нечетной.
3) Если число должно быть наибольшим, то его старшая цифра должна быть не меньше остальных. Учитывая 1) и 2) выбираем в качестве старшей цифры девятку. Тогда две оставшиеся меньше шести и обе четные.
4) С учетом того, что число должно быть наибольшим, выберем цифры четыре.

ответ: 944

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Условие задачи Нужно сделать на Python!!Ограничение времени, с 1Ограничение памяти, МБ 64Общее число попыток отправки 15На вход подается 2 строки. Нужно определить, можно ли превратить первую строку во вторую, заменяя одни буквы на другие, с учетом следующих правил:- участвуют только буквы русского алфавита а-я;- все буквы в нижнем регистре;- за один шаг можно преобразовать все вхождения одной буквы в другую.Входные данныеВходная информация поступает из стандартного ввода в виде одной строки. В этой строке содержатся две подстроки, разделенные пробелом. Ваше решение должно учитывать вариант, когда на вход поданы строки разной длины. Некорректные данные на вход не поступают, дополнительные проверки не требуются.Выходные данныеВ качестве ответа в стандартный вывод программа должна выводить 1 (если превратить можно) или 0 (если превратить нельзяПример 1Входные данные: привет приколВыходные данные: 1Преобразования (выводить не нужно):в ⇒ к (прикет)е ⇒ о (прикот)т ⇒ л (прикол)Пример 2Входные данные: ааббдд ддббааВыходные данные: 1Преобразования (выводить не нужно):д ⇒ я (ааббяя)а ⇒ д (ддббяя)я ⇒ а (ддббаа)Пример 3Входные данные: абаб ааахВыходные данные: 0Преобразовать нельзя, так как 'б' не сможет оказаться одновременно 'а' и 'х'.Примечания по оформлению решенияПри отправке решений на Java необходимо назвать исполняемый класс Main. В решении не нужно указывать пакет.Для работы со стандартным потоком ввода в JS используйте require('readline'), а для работы со стандартным потоком вывода - console.log(String(data)).Пример ввода-вывода на JS:const readline = require('readline');const rl = readline.createInterface(process.stdin, process.stdout);rl.on('line', (line) => { // Введенная строка в переменной line, тут можно написать решение console.log(String(result)); rl.close(); return;}).on('close', () => process.exit(0));Нужно сделать на Python!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Низамов
Gulyaev_Egorkina
stachevay-lera
stusha78938
faberlic0168
happych551
gbfedak220
Pavlushina-Novikova
Linichuk
самир1078
Guskov
Станиславович1830
ank9809
o-lala88387
Ludmila777020