skzzkt
?>

Написать программу на питон! У Даши есть два брата — Даня и Дима. А еще у нее есть n конфет, вкус i-й конфеты можно оценить как ai (чем больше число, тем конфета вкуснее, причем некоторые конфеты настолько невкусные, что это число отрицательное Недавно Даша поссорилась с Димой, поэтому теперь она хочет раздать своим братьям конфеты так, чтобы разница между суммарной вкусностью Даниных и Диминых конфет была максимальна. При этом вовсе не обязательно, чтобы Даня с Димой получили одинаковое число конфет, кто-то из них может даже не получить ни одной конфеты Даше разделить конфеты таким образом, чтобы Дима чувствовал себя максимально обиженным. Входные данные В первой строке ввода задано число n — количество конфет (1⩽n⩽106). В следующей строке через пробел перечислены числа ai — параметры вкусности конфет (−103⩽ai⩽103). Выходные данные Выведите единственное число — максимальную возможную разность между суммарной вкусностью конфет Дани и конфет Димы, которую можно достичь.

Информатика

Ответы

madjk

n = int(input())

him = 0

her = 0

a = list(map(int, input().split()))

for elem in a:

 if elem < 0:

   him += elem

 else:

   her += elem

print(her - him)

# логика такая создаём him и her для качества конфет для

# обиженного петуха и красотки соответственно

# к him прибавляем только отрицательные значения

# а к her -  положительные и выводим разницу

   

oldulo74
1.Найти фотографии своего класса.
2.Создать первый слайд:Вставить фотографию всего класса,написать кто сделал презентацию и сделать надпись "Наш класс".
3.Сделать второй слайд: написать о своём классном руководителе,вставить его фото и сделать заголовок.
4.Сделать четвертый слайд:написать о себе,вставить своё фото и сделать заголовок.
5.Создавать  слайдов столько сколько у тебя одноклассников,делать их так же как про себя.Спрашивать у них про них.
6.Предпоследний слайд сделать с пожеланиями своим одноклассникам.
7.На последнем слайде можно поставить красивую картинку или смайл и написать за внимание!
Евгеньевич-Куликов1614
Var
a,k,m,min,i,flag:integer;
    begin
            readln(a);
            m:=a; {сохраняю введенное значение и считаю кол-во цифр в числе}
              while m >0 do     
                  begin         
                          m:=m div 10;         
                          k:=k+1;     
                  end;     
min:=9; {записываю самое большое нечетное число}
{в цикле отсекаю последнюю цифру в числе и проверяю ее на нечетность. Если она нечетная и меньше числа min, то сохраняю ее в min и присваиваю переменной Flag 1. Если к концу программы в переменной flag  будет 1, значит хотя бы одна нечетная цифра в числе была, если flag=0 тогда в числе нет нечетных}
            for i:=1 to k do   
                      begin       
                             if   (a mod 10<=min)and(a mod 2<>0) then           
                                begin             
                                     min:=a mod 10;             
                                     flag:=1;           
                                end;       
                          a:=a div 10;   
                     end;         
      if flag=0 then           
                writeln('нет нечетных')         
      else             
                writeln(min);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на питон! У Даши есть два брата — Даня и Дима. А еще у нее есть n конфет, вкус i-й конфеты можно оценить как ai (чем больше число, тем конфета вкуснее, причем некоторые конфеты настолько невкусные, что это число отрицательное Недавно Даша поссорилась с Димой, поэтому теперь она хочет раздать своим братьям конфеты так, чтобы разница между суммарной вкусностью Даниных и Диминых конфет была максимальна. При этом вовсе не обязательно, чтобы Даня с Димой получили одинаковое число конфет, кто-то из них может даже не получить ни одной конфеты Даше разделить конфеты таким образом, чтобы Дима чувствовал себя максимально обиженным. Входные данные В первой строке ввода задано число n — количество конфет (1⩽n⩽106). В следующей строке через пробел перечислены числа ai — параметры вкусности конфет (−103⩽ai⩽103). Выходные данные Выведите единственное число — максимальную возможную разность между суммарной вкусностью конфет Дани и конфет Димы, которую можно достичь.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

purchase
marinadetsad
Бунеева
ivanovk3599
evge-borisova2
fedorenkoroman
Andreevna_Grebenshchikova155
pizniak
Yurevich
shutovaa3471
Сергеевна_Юрикович
Алина Ракитин1730
volodinnikolay19
elena-ruzadom
igor-790