Amelin-Alipova
?>

На СИ 1. Составить программу для вычисления значения функции у(х): у ={- 1, еслих < - 1х, еслих < 1, 1, еслих = 1. Значение аргумента вводится с клавиатуры, значение функции выводится на экран.

Информатика

Ответы

Blekjek730
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! begin   writeln('*** исходный массив ***');   var a: =matrrandom(2,4,-10,30);   a.println(4); writeln(4*a.colcount*'-');   writeln('п = ',a.elementsbyrow.where(t-> t.between(1,19))           .aggregate(1,(x,y)-> x*y)) end. пример *** исходный массив ***   24  16  22  12     2    5    1    8 п = 15360
larisau41
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На СИ 1. Составить программу для вычисления значения функции у(х): у ={- 1, еслих < - 1х, еслих < 1, 1, еслих = 1. Значение аргумента вводится с клавиатуры, значение функции выводится на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Stepanovich_Makarov
germanleon
Динков
Романенко
ekaterinasamoylova4705
igevskoemuseumkec
Arsen0708
Neveselova
director
vadimnechaev23150
Vrpeshka
qwqwweqw3
director
UvarovAndrei
smint056950