sv-opt0076
?>

Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии трамвая. Трамваи ходят по линии в обе стороны. Девочкам надо попасть в кинотеатр, который расположен около другой остановки этой линии. Они сели на трамваи, идущие в разные стороны и начали считать остановки, начиная с той на которой они вошли в трамвай. Они вышли у кинотеатра, причем для Маши это оказалась k-тая остановка, а для Даши m-тая. Напишите программу для определения количества остановок на кольцевой линии. Input format: В одной строке два натуральных числа k и m. Числа не превосходят 100. Output format: Одно число — ответ к задаче.

Информатика

Ответы

Владимир1524

#include <iostream>

#include <fstream>

using namespace std;

int main()

{

setlocale(0, " ");

ifstream inf("circle.in");

if (inf.is_open())

cout << "Файл circle.in открыт! \n"

<< endl;

else

{

cout << "Файл circle.in не найден!\n"

<< endl;

return -1;

}

int k, m;

inf >> k >> m;

ofstream outf("circle.out");

int s = k + m - 2;

outf << s;

cout << "Ваши данные обработаны!";

return 0;

}

valerii-borisovich550

Например, мы имеем кольцевую дорогу из 6 станций (картинка ниже).

Для пути от 4 до 2 получаем k = 5, m = 3.

Для получения количества станций из k и m достаточно сложить эти два числа и вычесть количество дважды посчитанных остановок.

n = k + m - 2

Код:

#include <iostream>int count_train_stations(int k, int m) {    return k + m - 2;}int main() {    int k, m;    std::cin >> k >> m;    std::cout << count_train_stations(k, m) << std::endl;}
Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии тр
Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии тр
Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии тр
bereza81

Для разделения целой и дробной частей десятичной дроби использовать запятую.

Вводить отрицательные числа со знаком минус или взять число в скобки.

Для обозначения процентов после числа вводить символ "%".

Обычную дробь нужно вводить, указывая и отделяя её от дробной пробелом.

Обозначение единиц измерения после чисел не вводится, только если это не денежные единицы.

перевод:

Для поділу цілої та дробової частин десяткового дробу використовувати кому.

Вводити негативні числа зі знаком мінус або взяти число в дужки.

Для позначення відсотків після числа вводити символ "%".

Звичайну дріб потрібно вводити, вказуючи і відокремлюючи її від дробу прогалиною.

Позначення одиниць виміру після чисел не вводиться, тільки якщо це не грошові одиниці.

zakaz

Объяснение:

1) Как при решении задач обозначают информационный объем сообщения?:

1)I

2) К какому виду программного обеспечения относят текстовые и графические редакторы, редакторы презентаций, мультимедийные проигрователи. (в ответе укажите только одно слово)

Прикладное

3) Как называется поименованная область памяти, хранящая в себе любые данные?( в ответе запишите слово)

Файл

4) Пользователь работал с каталогом C:\Документы\Договоры\Продажа. Сначала он поднялся на один уровень вверх, затем спустился в каталог затем спустился в каталог Покупка. Укажите полный путь каталога, в котором оказался пользователь:

2) C:/Документы/Договоры Покупка

5) В некотором каталоге хранился файл с именем ex.pas. После того как в этом каталоге создали подкаталог Pascal и переместили в него файл ex.pas, полное имя файла стало C:\Olimp\Ivanov\Pascal\ex.pas. Каким было полное имя этого файла до перемещения?:

2) C:/Olimp/Ivanov/ex.pas

6) Валя шифрует русские слова, записывая вместо каждой буквы её код (см. таблицу). Даны кодовые цепочки:

232323 654313 210201 203033

Найдите среди них ту, которая имеет только одну расшифровку, и запишите в ответе расшифрованное слово.

ответ - Бита

7) Агент 007, передавая важные сведения своему напарнику, закодировал сообщение придуманным шифром. В сообщении присутствуют только буквы из приведённого фрагмента кодовой таблицы. Определите, какое сообщение закодировано в строчке

€ ? ? € ? ? €

М - € ? ; Ы - ? ? € ; Ш - ? ? ; К - ? € ; А - ? € ?

€ ? ? € ? ? € = МАК.

8) К графическим форматам растровой графики относят?:

1) bmp

4) TIFF

9) Как называется вид компьютерной графики, основанная на математических вычислениях?:

3) фрактальная

10) Процесс оформления текста в информатике называют форматированием. К чему оно может быть применено?:

5) все варианты верны

11) Согласитесь или не согласитесь с утверждениями:

1) Отличием текстового редактора от текстового процессора является то, что функционал текстового редактора шире. Нет

2) Список - демент визуализации информации демент? Не понятно что это (

3) Gimp- растровый графический редактор ДА

4) Delete удаляет символ справа от курсора Да

12) Как называется минимальный объект компьютерной презентации?:

2) слайд

13) Сколько Кбайт содержится в 24576 битах? ( в ответе укажите число, единицы измерения писать не нужно)

ответ - 3

14) Чему равна разрядность двоичного кода , если количество кодовых комбинаций равно 512?

ответ - 9

15) Укажите информационные процессы:

1) сбор

3) хранение

4) обработка

5) передача

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на C++ Кольцевая линия Маша и Даша живут около одной остановки кольцевой линии трамвая. Трамваи ходят по линии в обе стороны. Девочкам надо попасть в кинотеатр, который расположен около другой остановки этой линии. Они сели на трамваи, идущие в разные стороны и начали считать остановки, начиная с той на которой они вошли в трамвай. Они вышли у кинотеатра, причем для Маши это оказалась k-тая остановка, а для Даши m-тая. Напишите программу для определения количества остановок на кольцевой линии. Input format: В одной строке два натуральных числа k и m. Числа не превосходят 100. Output format: Одно число — ответ к задаче.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

skononova01
soa8690
shurshin6975
format-l3364
denisrogachv
galinasemyan689
abuzik
Ilin1022
korotinadasha07
alekseymedvedev1981
pizniak
Евгеньевич-Куликов1614
Найдите значение x в неравенстве 634 8
maksimovskiy7657
nat5555
madina27821667