Мы постоянно участвуем в действиях, связанных с передачей информации. Люди передают друг другу приказы, отчёты о проделанной работе, публикуют книги, научные статьи, рекламные объявления. Передача информации происходит при чтении книг, при просмотре телепередач.
В процессе передачи информации обязательно участвуют источник и приёмник информации: источник передаёт информацию, а приёмник её принимает.
Между ними действует канал передачи информации — информационный канал (канал связи).
Схема передачи информации
per1.png
Органы чувств человека являются биологическими информационными каналами.
Техническими информационными каналами являются телефон, радио, телевидение, компьютерные сети.
По характеру передачи информационный канал может быть односторонним или двусторонним.
Односторонний канал передаёт информацию только от источника к приёмнику.
Двусторонний канал передаёт информацию как от источника к приёмнику, так и в обратном направлении.
При переходе дороги на регулируемом перекрёстке ты (приёмник информации) воспринимаешь зелёный сигнал светофора (источника информации) как разрешение перейти дорогу. В этом случае информация передаётся в одну сторону, но бывают такие ситуации, когда происходит взаимный обмен информацией.
Играя в компьютерную игру, ты постоянно обмениваешься информацией с компьютером: воспринимаешь сюжет, правила и текущую ситуацию, анализируешь полученную информацию и передаёшь компьютеру с клавиатуры или мыши некоторые управляющие команды.
В свою очередь, компьютер принимает и обрабатывает твои команды, отображая результат обработки на экране дисплея. Этот взаимный обмен информацией происходит на протяжении всей игры. В случае просмотра телепередачи всей семьёй источник информации один (телепередача), а приёмников несколько (члены семьи).
Для того чтобы передавать информацию на большие расстояния, человек использует различные средства связи.
Средства связи передачи информации на расстояние. К традиционным средствам связи относятся сигнализация, почта, телеграф, телефон, радио, телевидение, Интерн
#include <iostream>
using namespace std;
int main()
{
int N, x, y;
cin >> N >> x >> y;
for (int i = x; i <= N; i += y)
{
cout << i << " ";
}
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
using namespace std; // Пространство имён
int main()
{
int N, x, y; // Объявление целочисленных переменных по условию
cin >> N >> x >> y; // Ввод значений переменных с клавиатуры по условию
for (int i = x; i <= N; i += y) // Начинаем с x, идем до N [включительно], с шагом в y
{
cout << i << " "; // Выводим значения через пробел
}
}
Поделитесь своими знаниями, ответьте на вопрос:
Система Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 3 и оканчивающихся на 4.
pascal
Объяснение:
program summa;
var i, s: integer;
begin
WriteLn('Введите числа (или 0, чтобы закончить: ');
repeat
Write('i = ');
ReadLn(i);
if (i mod 3 = 0) and (i mod 10 = 4) then s := s + i;
until i = 0;
WriteLn('Сумма введенных натуральных чисел, кратных 3 и оканчивающихся на 4, равна ', s);
end.