Константиновна
?>

4. Составить программу для решения следующей задачи. Определить, имеется ли среди двузначных положительных целых чисел a, buс, заданных с клавиатуры, хотя бы одно четное. Полученные числа выводитьна экран.​

Информатика

Ответы

Fomin Korablev1781

Объяснение:

Программа на Питоне:

a=[]

print('Введите числа:')

for i in range(3):

   a.append(int(input()))

print('четные числа: ')

for i in range(3):

   if (a[i] % 2) == 0:

       print(a[i], end=' ')

Кристина Валентиновна

1. Число не меньше 50 и четное: 50

2. Опечатка, вероятно. Либо наибольшее X - тогда 99, либо наименьшее натуральное x, и тогда это будет 1, либо НЕ меньше 100, тогда 101

3. Немного запутано, но по идее: число должно быть четным и меньше 10. Максимальное такое число: 8

4. X больше либо равен 7, или x меньше 6. Единственное число, которое НЕ подходит под эту формулу: 6

10. Обычное уравнение вида (4+3)^n+9 = 58 При том что n только натурален. Очевидно, что n = 2

17. Надо просмотреть каждую пару чисел и поставить плюсик, если первое больше 15 или второе больше 9. Я загнул пять пальцев, лучше меня перепроверить

25. У эсминца всего 2500 из которых 500 принадлежат также и фрегату. А всего-всего их 4500. Значит ТОЛЬКО эсминцу принадлежат 2000, ТОЛЬКО фрегату тоже 2000, а фрегату всего 2000+500 = 2500. Я понимаю, что ничего из этой писанины понять невозможно, так что прилагаю картиночку, написанную замороженной куриной лапой.

45. Столько писанины, а проще взять листочек в клеточку и самому побыть роботом, исполняя команды. Если у меня все верно, то за один цикл получается общее смещение на 1 вверх и 1 вправо. Значит за 5 циклов будет смещение (5,5) и чтоб переместиться в начало надо дать команду (-5,-5)

53. Третья строчка аналогична: a = 2*4 + 7*3. Любой второклассник скажет, что это 29. Четвертая строчка аналогична: b = 30-29 = 1. Таким образом, у нас a = 29, b = 1. А просят найти именно b. В ответ пишем 1


Объясните как это считать все к а к э т о де ла т ь. заранее целую в пупок. вот прям до вечера нужно
phiskill559

38

Объяснение:

Условие i mod 2 = 0 означает, что i должно быть четным.

Условие i div 5 = 4 означает, что i находится в промежутке от 20 до 24 включительно.

Требуется сказать, какое последнее i было добавлено в сумму s, что сумма стала равной 424, а i удовлетворяет хотя бы одному из условий выше.

Найдем сумму четных чисел с 2 до 18 включительно.

\frac{2+18}{2}*9=90 - этого мало

Добавим еще сумму чисел от 20 до 24 включительно.

90+\frac{20+24}{2}*5=200 - этого тоже мало.

Поэтому искомое значение i будет среди четных чисел больших 24.

Пусть количество четных элементов, начиная с 26, равно n, добавив которые к 200 можно получить 424. Тогда:

200+\frac{2*26+2(n-1)}{2}*n=424,\\n(n+25)=224,\\n^2+25n-224=0,\\D=25^2+4*224=1521=39^2\\n_{1,2}=\frac{-25\pm39}{2}\\n_1=\frac{-25-39}{2}=-32,\\n_2=\frac{-25+39}{2}=7

Среди найденных значений подходит только n=7.

Тогда последний требуемый четный элемент равен 26+2*(7-1)=38.

Таким образом, путем суммирования (2+4+...16+18)+(20+21+22+23+24)+(26+28+...+36+38) можно получить 424.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

4. Составить программу для решения следующей задачи. Определить, имеется ли среди двузначных положительных целых чисел a, buс, заданных с клавиатуры, хотя бы одно четное. Полученные числа выводитьна экран.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

helenavalenti2846
maxkuskov2485
Alyona1692
Наталья Юрьевич1228
Газинурович
Stenenko
ikhilovb76
ev27076878
alexderru
iptsr4968
Семеновна-Павел
chernova1exei862
Berezovskaya
Astrians
ovdei71
▲