braigon974
?>

I 3. Составьте программу для формирования списка фамилий учащихся.Вывести на экран фамилию учащегося под определённым номером.Введите количество учащихся: 5Введите фамилии:ИвановПетровСидоровСергееваАндрееваВведите номер учащегося: 3Искомая фамилия: Сидоров​

Информатика

Ответы

ibswoklol1362

Объяснение:

Программа на Питоне:

a=[]

n=int(input('Введите количество учащихся: '))

print('Введите фамилии:')

for i in range(n):

   a.append(input())

i=int(input('Введите номер учащегося:'))

print('Искомая фамилия: ',a[i-1])

Андреевна-Арзуманян1109
Перевод чисел из двоичной системы счисления в восьмеричную. Для записи двоичных чисел используются две цифры, то есть в каждом разряде числа возможны 2 варианта записи. Решаем показательное уравнение: 2 = 2i . Так как 2 = 21, то i = 1 бит. Каждый разряд двоичного числа содержит 1 бит информации. Для записи восьмеричных чисел используются восемь цифр, то есть в каждом разряде числа возможны 8 вариантов записи. Решаем показательное уравнение: 8 = 2i . Так как 8 = 23, то i = 3 бита. Каждый разряд восьмеричного числа содержит 3 бита информации. Таким образом, для перевода целого двоичного числа в восьмеричное его нужно разбить на группы по три цифры, справа налево, а затем преобразовать каждую группу в восьмеричную цифру. Если в последней, левой, группе окажется меньше трех цифр, то необходимо ее дополнить слева нулями. Переведем таким двоичное число 1010012 в восьмеричное: 101 0012 => 1 × 22 + 0 × 21 + 1 × 20 0 × 22 + 0 × 21 + 1 × 20 => 518.
machkura

1. Во втором письме содержится меньшее количество информации на 5 500 бит

2. 256 секунд

Объяснение:

1.

I = К * i, где

I - информационный объём письма (документа)

К - количество символов в письме (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

N = 2^i, где

N - мощность алфавита (количество символов в алфавите)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

Дано:

K₁ = 25 строк * 50 символов = 1 250 символов

N₁ = 256 символа

K₂ = 2 страницы * 15 строк * 30 символов = 900 символов

N₂ = 32 символа

Найти:

I ₁ - I₂

256 = 2^i ₁

i₁ = 8 бит

32 = 2^i ₂

i₂ = 5 бит

I₁ = 1 250 * 8 = 10 000 бит

I₂ = 900 * 5 = 4 500 бит

I ₁ - I₂ = 10 000 - 4 500 = 5 500 бит

2.

I = К * i, где

I - информационный объём сообщения (документа)

К - количество символов в сообщении (документе)

i - информационный вес символа (количество бит, которым кодируется 1 символ)

К = V * t, где

K - количество символов в сообщении (документе)

V - скорость печати принтера

t - время печати принтера

Дано:

V = 1 024 символа/с

I = 256 Кбайт = 262 144 байт

i = 1 байт (предположительно)

Найти:

t

I = К * i

К = I / i

К = 262 144 / 1 = 262 144 символов

К = V * t

t = К / V

t = 262 144 / 1 024 = 256 секунд

1 Кбайт = 1024 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

I 3. Составьте программу для формирования списка фамилий учащихся.Вывести на экран фамилию учащегося под определённым номером.Введите количество учащихся: 5Введите фамилии:ИвановПетровСидоровСергееваАндрееваВведите номер учащегося: 3Искомая фамилия: Сидоров​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Valentina
Vitalevich1799
asvirskiy26
nevasoundmsk36
Анатольевич1707
chernova1exei862
Роман1406
Natalya1895
Спиридонова
ecogoi
vfif-804828
inbox466
Владислав-Александр32
kriapex
osandulyak