zakupka-marion
?>

Интересно, какое максимальное число можно получить из числа 6789012345 путем вычеркивания в нем пяти цифр? Правильно: 92345 Напишите программу, которая по введенному числу и количеству цифр, которые необходимо вычеркнуть, получает максимальное число. Формат ввода В первой строке входного файла записаны два числа N и M — количество цифр в данном числе и количество цифр, которое необходимо вычеркнуть (0 ≤ M ≤ N ≤ 100 Во второй строке записано ровно N цифр — исходное число. Число может содержать лидирующие нули. Формат вывода В выходной файл выведите ответ на задачу — искомое максимальное число. НА ЛЮБОМ ЯЗЫКЕ

Информатика

Ответы

tarigor
1)
var s:string;
     i:integer;
     f:boolean;
begin
  f:=false;
  write ('S = ');
  readln(s);
  for i:=1 to length(s) div 2 do
   if s[i]=s[length(s)-i+1] then f:=true else 
    begin
      f:=false;
      break;
    end;
  if f then writeln ('PALINDROM') else writeln ('NOT PALINDROM');
  readln;
end.

2)
var a,b:integer;
     count,j:integer;
function palindr (n:integer):boolean;
var s:string;
     i:integer;
begin
  palindr:=false;
  str (n,s);
    for i:=1 to length(s) div 2 do   
      if s[i]=s[length(s)-i+1] then palindr:=true else
        begin
           palindr:=false;
           break;
        end;
end;
begin
  write ('A = ');
  readln(a);
  write ('B = ');
  readln(b);
  count:=0;
  for j:=a to b do
    if palindr(j) then
     begin
       write (j,' ');
       count:=count+1;
     end;
  writeln;
  writeln ('Kol-vo palindromov: ',count);
  readln;
end.
Yeremeev

см вложение с уважением Александр и это не я а не в курсе что это за мной бегал по английски и это не я а теперь ЗАБУДЬТЕ и в курсе это я не могу найти этот вопрос не найдено ни одной видеозаписи в этом году в ответ на этот вопрос не

Объяснение:

Питти я не могу найти этот вопрос не найдено ни одной видеозаписи в этом году в ответ на этот вопрос не найдено ни одной видеозаписи в этом году в ответ на этот вопрос не найдено ни одной видеозаписи в этом году в ответ на этот адрес ное знаю что я могу в любой город нер

ооо

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Интересно, какое максимальное число можно получить из числа 6789012345 путем вычеркивания в нем пяти цифр? Правильно: 92345 Напишите программу, которая по введенному числу и количеству цифр, которые необходимо вычеркнуть, получает максимальное число. Формат ввода В первой строке входного файла записаны два числа N и M — количество цифр в данном числе и количество цифр, которое необходимо вычеркнуть (0 ≤ M ≤ N ≤ 100 Во второй строке записано ровно N цифр — исходное число. Число может содержать лидирующие нули. Формат вывода В выходной файл выведите ответ на задачу — искомое максимальное число. НА ЛЮБОМ ЯЗЫКЕ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Anait_Natalya451
kav511
dima0218687
konstantin0112
nataljatchetvertnova
director
Эдгеева219
opel81
sveta740450
evolkova-73
Zhulanova-IP501
emartynova25
kondrashovalf6404
sryzhova6392
sales5947