Puschdom
?>

1. В массиве хранятся данные о ежедневной температуре в течение августа (случайные числа от 15 до 25 Составьте программу для нахождения среднемесечной температуры. 2. Массив содержит информацию об отметках по информатике 20 учащихся класса. Отметки вводятся с клавиатуры. Составьте программу, которая вычисляет средний по предмету и количество учащихся с отметками выше среднего

Информатика

Ответы

МуратМарина1140

program xxx;

var i, m, p, n : integer;

t : array[1..31] of real;

begin

writeln('введите температуру ')

for i:=1 to 31 do

readln(t[i]);

m:=0; p:=0; n:=0;

for i:=1 to 31 do

begin

if t[i]<0 then m:=m+1;

if t[i]>0 then p:=p+1;

if t[i]=0 then n:=n+1

end;

writeln('Дней с отрицательной температурой было - ', m);

writeln('Дней с положительной температурой было - ', р);

writeln('Дней с нулевой температурой было - ', n);

readln

end.

Объяснение:

Прописка

Bondarev_Ayupova795
// PascalABC.NET 3.0, сборка 1128
begin
  var a:=ArrRandom(20,-10,19);
  a.Println(','); // 1
  var b:=ReadArrInteger('Введите 10 целых чисел',10); // 2
  Writeln('Количество положительных элементов ',
    a.Where(x->x>0).Count); // 3
  for var i:=0 to 19 do
    if a[i]<0 then a[i]:=0;
  Writeln('Массив А после замены отрицательных'); a.Println(','); //4
  Writeln('Сумма положительных элементов ',
    a.Where(x->x>0).Sum) // 5
end.

Тестовое решение:
14,8,9,-5,6,3,3,-10,-8,18,7,13,2,17,-1,0,4,-3,8,-8
Введите 10 целых чисел -5 0 13 -7 -14 11 8 19 -3 -1
Количество положительных элементов 13
Массив А после замены отрицательных
14,8,9,0,6,3,3,0,0,18,7,13,2,17,0,0,4,0,8,0
Сумма положительных элементов 112
Natalya1895
Задача №1

var a:array [1..20] of integer;     
i:integer;
begin 
randomize;   
for i:=1 to 20 do begin   
a[i]:=random(19-(-10)+1)+-10;     
write (a[i],' ');           
end;
end.

Задача №2

var a:array [1..20] of integer; 
i:integer; 
begin 
writeln('Введите числа в интервале [-20;29]'); 
for i:=1 to 10 do read(a[i]); 
for i:=1 to 10 do 
if (a[i]>-29) and (a[i]<20) then write(a[i],' '); 
end.

Задача №3

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+1; 
end; 
writeln('Количество положительных элементов массива = ', sum); 
end.

Задача №4

var a:array [1..20] of integer; 
i:integer; 
begin 
randomize; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
if a[i]<0 then a[i]:=0; 
write (a[i],' '); 
end; 
end.

Задача №5

var a:array [1..20] of integer; 
i,sum:integer; 
begin 
randomize; 
sum:=0; 
for i:=1 to 20 do 
begin 
a[i]:=random(19-(-10)+1)+-10; 
write (a[i],' '); 
if a[i]>0 then sum:=sum+a[i]; 
end; 
writeln('Сумма положительных элементов массива = ', sum); 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. В массиве хранятся данные о ежедневной температуре в течение августа (случайные числа от 15 до 25 Составьте программу для нахождения среднемесечной температуры. 2. Массив содержит информацию об отметках по информатике 20 учащихся класса. Отметки вводятся с клавиатуры. Составьте программу, которая вычисляет средний по предмету и количество учащихся с отметками выше среднего
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

GridnevaVNIGNI&quot;
Николаевна1564
rashad8985
Олимов Протопопова
Darialaza
Bolshakova Shigorina
alfaantonk
aerendzhenova5
kun1969
galustyanvitaly4842
zdv686857
inulikb
donliolik
Manyaya
Цветкова