Кедрин Карлен
?>

Решить ! язык программирования: паскаль. 8 класс. составить программу, которая находит значение выражения (a+1)^n n вводится с клавиатуры. нужно решить!

Информатика

Ответы

Pgr100
Var   count, i, d1, d2, d3, d4, d5, d6: integer; const   min = 189980;   max = 205505; begin   count : = 0;   for i : = min to max do       begin           d1 : = i div 100000;           d2 : = i mod 100000 div 10000;           d3 : = i mod 10000 div 1000;           d4 : = i mod 1000 div 100;           d5 : = i mod 100 div 10;           d6 : = i mod 10;           if ( (d6 * 100000) + (d5 * 10000) + (d4 * 1000) + (d3 * 100) + (d2 * 10) + d1 ) = i          then               count : = count + 1;       end;   writeln('в промежутке от ', min, ' до ', max, ' ', count, ' счастливых билетов'); end.
ipKAV85
Написали бы язык программирования хотя бы. вот вам на java ^_^ import java.io.bufferedreader; import java.io.inputstreamreader; public class prog{   public static void main(string[] args) throws exception{   bufferedreader reader=new bufferedreader(new   inputstreamreader(system.in));   system.out.println("введите гипотенузу: ");   int c=integer.parseint(reader.;   system.out.println("введите длину катета: ");   int a=integer.parseint(reader.;   double b=math.sqrt(c*c-a*a);   double p=a+b+c;   system.out.println("периметр: "+p);   double s=(a*b)/2;   system.out.println("площадь: "+s); }}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить ! язык программирования: паскаль. 8 класс. составить программу, которая находит значение выражения (a+1)^n n вводится с клавиатуры. нужно решить!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

opel81
nalich8524
mirsanm26249
itartdesignprof
marketing6
artemkolchanov24
Zebra198383
КириллЕгорова1906
cvetprint
svo1961
familumid
Александр Сергей
katcoffe3
hrim5736
platonovkosty