Drugov_Vladimirovna
?>

Как-то раз в домашнем задании Леше попалась интересная задача: «Найдите количество магических чисел, меньших или равных N». Так как Леша увлекается программированием, то он очень хотел бы решить данную задачу с программы, но, к сожалению, ему не хватает на это навыков Леше, написав программу, которая находит количество магических чисел, не превышающих N. Формат входных данных Первая строка входных данных содержит единственное число N (1⩽N⩽10^9 Формат результата Программа должна вывести одно число — количество магических чисел, не превышающих N. Два вектора a и b заданы в тр...

Информатика

Ответы

zybin41iz81


Program Djonny1981;
uses crt;
const
  m=5;
var
  a: array[1..m,1..m] of integer;
  i, j: integer;
  sum: integer;
begin
  randomize;
  sum:=0;
  for i:=1 to m do
    begin
      for j:=1 to m do
        begin
          a[i,j]:=random(101)-50;
          write(a[i,j]:5);
        end;
        writeln();
    end;
  for i:=1 to m do
    for j:=1 to m do
      if j mod 2 = 0 then {вот здесь проверка, чётный ли столбец}
         sum := sum + a[i,j];
  writeln('Сумма элементов чётных столбцов равна ',sum);
  if sum>0 then
      for i:=1 to m do
        for j:=1 to m do
          if i mod 2 = 1 then
            a[i,j]:=a[i,j]*a[i,j]
    else
      for i:=1 to m do
        a[m-i+1,i]:=a[m-i+1,i]+2;
  for i:=1 to m do
    begin
      for j:=1 to m do
        write(a[i,j]:5);
      writeln();
    end;
end.

bmargarita

во всех этих задачах используются 2 формулы  (объем)I=k*i; (мощность)N=2^i

1) 8=2^i => i=3, объём= 3*20=60 бит

2)вес одного символа 4096/1024=4 бит => i=4, мощность (N) = 2^i => N=2^4=16

3)12288/8=1536 байт, далее 1536/1024=1,5 Кбайт

4)для начала переведем объем кбайт и биты. (из предыдущей задачи это 12288 бит); после найдем i i=12288/4096=3. далее мощность (N)=2^3=8

5)один символ занимает 4 бита (2^4=16) 1/64 часть мегабайта = 1024 * 1024 * 8 / 64 = 131072 бита значит 131072 / 4= 32768 символов.

6)находим количество(k) 4*30*50=6000, кол-во информации (объем (I) ) из байт переводим в бит. 4500*8=36000 бит. далее находим i; i=I(объем)/k(кол-во); i=36000/6000=6. N=2^6=64.

7)может не 1,5*1023, а 1,5*10^23? N=4; i=2. находим объём 2*1,5*10^23. I=3*10^23.

8)всего двухзначных чисел 100. (00, 01, 02, 03, 04, 05, 06, 07, 08, 09, 10, 11, 12 и тд. ) значит 2^i=100. близжайшее значение i в данном случае 7. Так как если 6, то 2^6=64, 100-64=36. если i=7, то 2^7=128. 100-128=-28 (ну по факту разница в 28 единиц.) что ближе 36 или 28? следовательно ответ 7.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Как-то раз в домашнем задании Леше попалась интересная задача: «Найдите количество магических чисел, меньших или равных N». Так как Леша увлекается программированием, то он очень хотел бы решить данную задачу с программы, но, к сожалению, ему не хватает на это навыков Леше, написав программу, которая находит количество магических чисел, не превышающих N. Формат входных данных Первая строка входных данных содержит единственное число N (1⩽N⩽10^9 Формат результата Программа должна вывести одно число — количество магических чисел, не превышающих N. Два вектора a и b заданы в тр...
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nane2924329
Alsergus7811
smartschoolfili6
d111180
mar1030
Девяткина_Арсений
andre6807
ilyagenius
Оксана Николаевич
bykovaam
Dmitrii1763
natalili32
Nikolaevich824
впвыпвып-Зуйков629
nalekseeva62