Вот ссылка на готовую прогу → https://yadi.sk/d/pRyX2bUGMIdWsw
Объяснение:
Это было сделана на среде программирования Delphi 7 в консольном режиме.
P.S: Код программы↓
var
i,s,n: longint; // объявляем переменные
begin
SetConsoleCP(1251); // для вывода в консоль русские символы
SetConsoleOutputCP(1251); // для вывода в консоль русские символы
write('Здравствуйте! Введите любое число: '); //вывод сообщения
readln(n); // запишем то, что написал пользователь
s:=0; // присвоим для начало 0
for i:=2 to n do
if i mod 2 = 0 then s:=s+i;
writeln('Ваше число: ', s); //выводим S
readln;
end.
Я плохо объясняю, но думаю ты понял.
Поделитесь своими знаниями, ответьте на вопрос:
Исполнитель U18 преобразует число, записанное на экране. У исполнителя есть три команды, которым присвоены номера: 1. Прибавить 1 2. Прибавить 2 3. Умножить на 2 Сколько существует программ, для которых при исходном числе 2 результатом является число 12 и при этом траектория вычислений не содержит число 10?
#include <iostream>
#include<iomanip>
#include<ctime>
using namespace std;
int main()
{
srand(time(0));
int sum = 0;
int k = 0;
int arr[3][4];
//Создание и последующий вывод массива
for (int i = 0; i < 3; i++)
{
for (int j = 0; j < 4; j++)
{
arr[i][j] = -100 + rand() % 201;
cout << fixed<<setw(3)<<arr[i][j] << " ";
}
cout << endl << endl;
}
//Задание
for (int i = 0; i < 3; i++)
{
for (int j = 0; j < 4; j++)
{
if (i == j)
sum += arr[i][j];
if (arr[i][j] > 0)
k++;
}
}
cout << endl;
cout << "Sum = " << sum << " Kol-vo = " << k;
return 0;
}
Объяснение: