annaar497
?>

CРОЧНО! Решите задачу на C++ Даны два числа a и b. Ваша программа должна поменять два числа местами, если a Формат входных данных Даны два целых числа a и b (∣∣a∣∣, ∣∣b∣∣≤109 Формат выходных данных Требуется вывести числа в том же формате, в котором они вводились. входные данные 3 5 5 3 выходные данные 11 4 11 4

Информатика

Ответы

saytru5850

Условие:

Даны два числа: a и b. Ваша программа должна поменять два числа местами, если a < b, после чего вывести их.

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int a, b;

   cout << "Введите a, b: ";

   cin >> a >> b;

   if (a < b)

   {

       swap(a, b);

   }

   cout << a << " " << b;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека для локализации (возможно, будет работать без нее)

using namespace std;  // Пространство имен

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация (возможно, будет работать без нее)

   int a, b;  // Создание целочисленных переменных

   cout << "Введите a, b: ";  // Вывод текста в консоль

   cin >> a >> b;  // Вводим с клавиатуры

   if (a < b)  // Если а < b

   {

       swap(a, b);  // Меняем a и b местами

   }

   cout << a << " " << b;  // Вывод а и b через пробел

}

AlekseiMardanova
Program z3;
var A:array[1..3] of string;
var B:array[1..3] of string;
i,k:byte;
begin
writeln('Ввод названий газет: ');
  for i:=1 to 3 do begin write('[',i,']');readln(A[i]); end;
writeln('Ввод подписчиков: ');
  for i:=1 to 3 do begin write('[',i,']'); readln(B[i]); end;

for i:=1 to 3 do begin
  if (A[i]='правда') and (B[i]= 'петров') then begin k:=i;
  writeln('Да, Петров выписывает газету ',A[i]); end;
 end;
end.

Ввод названий газет: 
[1]Книга
[2]Правда
[3]Вера
Ввод подписчиков: 
[1]Библиотекарь
[2]Петров
[3]Гундяев
Да, Петров выписывает газету Правда
Adassa00441
Program z3;
const n=3;
var A:array[1..n] of string;
var B:array[1..n] of string;
i,k:byte;

begin
writeln('Ввод названий газет:');
for i:=1 to n do
 begin write('[',i,'] '); readln(A[i]);end;
writeln('Ввод фамилий подписчиков:');
for i:=1 to n do
 begin write('[',i,'] '); readln(B[i]);end;
k:=0;
for i:=1 to n do
 if (A[i]='Правда') and (B[i]='Петров') then k:=i;
if k<>0 then writeln('Да, Петров выписывает Правду.')
        else writeln('Петров не выписывает Правду.');
end.

Пример:
Ввод названий газет:
[1] Правда
[2] Мир
[3] Атеист
Ввод фамилий подписчиков:
[1] Петров
[2] Дружаев
[3] Базаров
Да, Петров выписывает Правду.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

CРОЧНО! Решите задачу на C++ Даны два числа a и b. Ваша программа должна поменять два числа местами, если a Формат входных данных Даны два целых числа a и b (∣∣a∣∣, ∣∣b∣∣≤109 Формат выходных данных Требуется вывести числа в том же формате, в котором они вводились. входные данные 3 5 5 3 выходные данные 11 4 11 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

market-line5260
Ye.Vadim
Zhamynchiev
lighturist
Девяткина_Арсений
tokarevmax
YelenaZOLTANOVICh105
Олег86
retropluse832
Середа-Сергеенков980
Вертуалды шындықтың адамға зияны ​
Lukina
Fateevsa9
nelli-bi6
m-illarionov
re22no22