if (-1 <= x <= 2 and -5 <= y <= 4) or (2 < x <= 5 and 2 <= y <= 4) or (-5 <= x < -1 and -5 <= y <= -2):
d43irina
28.11.2021
Первый тип — линейный алгоритм; такой, в котором все действия выполняются в строгом порядке, последовательно, одно за другим. Типичный жизненный пример такого алгоритма — рецепт пирога. Второй тип — разветвляющийся алгоритм; такой, в котором выполняются те или иные действия в зависимости от выполнения или невыполнения некоего условия. Пример из жизни — правило перехода улицы по светофору. Если горит красный — стоим, если горит зеленый — идем. Третий тип — циклический алгоритм; такой, в котором присутствуют повторяющиеся действия с какой-либо изменяющейся величиной, так называемым параметром. Пример — колка дров. Берем полено — колем топором, берем второе полено и т. д. , пока поленья не закончатся, и эта работа нам не надоест.
Shipoopi8
28.11.2021
Program pr1; const n=19; var i, l: integer; Dat: array [1..n] of integer; New: array [1..n] of integer; begin write('Dat: '); for i:=1 to n do begin Dat[i]:=random(30)-15; write(Dat[i],' '); end; writeln(); write('New: '); l:=0; for i:=1 to n do if (Dat[i]>=0) and (Dat[i] mod 8<>0) then begin l:=l+1; New[l]:=Dat[i]; end; for i:=1 to l do write(New[i],' '); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
написать программу нужно найти количество точек, принадлежащих закрашенной областиКакое будет условие после счётчика?
if (-1 <= x <= 2 and -5 <= y <= 4) or (2 < x <= 5 and 2 <= y <= 4) or (-5 <= x < -1 and -5 <= y <= -2):